[ubuntu-uk] dapper kubuntu - dial up external modem configure? (SOLVED sort of)

alan c aeclist at candt.waitrose.com
Sun Dec 17 09:30:00 GMT 2006

alan c wrote:
> I need to configure a dial up modem - not an internal winmodem but a
> serial connected external modem. I am unfamiliar with kppp and am not
> having much success so far, although I am putting in the sort of obvious
> entries with my limited knowledge.
> If anyone is familiar with this method I would be grateful for some 
> hand holding.
> (I am used to kinternet in my suse days which seemed to be very easy
> but I cannot see kinternet with kubuntu repositories)
> The machine is normally used with a lan (adsl router) connection to
> internet, but I know that, at least with suse, I can have dial up
> running concurrently.
> I can get as far as hearing the modem dial out, and also hear the
> response from the isp (waitrose), then the log indicates that 
> something is hanging or whatever-
> OK
> ATM1L3
> OK
> ATDT0844 056 7100
> CONNECT 115200
> ('starting pppd')
> (logging onto network.....)
> (my comment - looks like it is hanging here with pppd not starting and 
> no sign of logging onto network)
> (The ppd daemoin diesd unexpectedly, Exit status 1) -
> details:
> Dec 16 23:43:50 mesh-pc pppd[5249]: The remote system is required to 
> authenticate itself
> Dec 16 23:43:50 mesh-pc pppd[5249]: but I couldn't find any suitable 
> secret (password) for it to use to do so.
> Dec 16 23:43:50 mesh-pc pppd[5249]: (None of the available passwords 
> would let it use an IP address.)

I have now got it working , phew a struggle which I was not expecting.

The modem was dropping back to a low speed (9600) so I needed to 
reduce the target speed from 115200 down to 57600.

The kppp error message:
The pppd daemon died unexpectedly!
Exit status: 1
See 'man pppd' for an explanation of the error codes or take a look at 
the kppp FAQ on http://developer.kde.org/~kppp/index.html

man pppd did not seem to help (me) but the faq 
does include this issue, not fully resolved:

pppd died - The remote system is required to authenticate itself ...
As far as I can tell there are two causes for this problem:

     * /etc/ppp/options contains the auth option. Simply put a # 
comment character in front and try again.
     * Your system already has a default route. Have you set up a 
local network ? In thise case recent versions of pppd will behave as 
if the auth had been specified. To override this you may add noauth to 
the pppd arguments in kppp' setup dialog. Alternatively you could take 
down the local network prior to dialing in. I'd be thankful if someone 
could provide instructions on how to peacefully combine the two 
network connections.

I modified the file /etc/ppp/options and it did not seem to help by 
itself at least. I have left it as modified, not sure if it is 
necessary for me here though. (yes it is necessary - later confirmed, 
auth needs to be commented out).

I do have a local network. I tried adding noauth to the pppd arguments 
but got a later error stating I had to be root to use the noauth 
argument. I dont know how to do that within the pppd sequence so.....

I played around with the kppp route options, opting for default 
Gateway, *and* for it to set its own default route to the gateway.

I also disabled the network interface card nic using system settings, 
network settings, (admin mode).

At last I could dial up, albeit with some inconvenience.

Are other dialup interfaces easier to set up?

Whatever suse (9.3 - 10.1) does with its so called Kinternet, it is a 
whole bunch easier, particularly thinking newbies. What chances of 
adopting some of the same tricks?
alan cocks
Kubuntu user#10391

More information about the ubuntu-uk mailing list