[ubuntu-studio-users] Thinkpad X220t: extra-buttons underneath the display don't work in tablet mode

Erich Eickmeyer eeickmeyer at ubuntu.com
Thu Mar 26 15:53:44 UTC 2020

Hi Daniel,

On Thursday, March 26, 2020 3:45:07 AM PDT ds wrote:
> Hallo ubuntu studio mail list members,
> [snip]
> The problem: Turned into tablet mode, the buttons stop working.
> Remapping them then is not possible, and also xev doesn't report
> anything. So I guess the device seems to not detect the buttons.
> Further information: I read in a thinkpad forum, that there is a
> magnetic sensor. If I hover the display in tablet mode a few
> centimeters, the buttons work again like in laptop mode. In bios the
> XF86PowerButton at the display also works in tablet mode, so it seems to
> be no hardware problem (the other two buttons I can not test. They seem
> to not be mapped during the startup process, neither in laptop nor
> tablet mode). Before I had a Debian installed with gnome 3 desktop
> environment and there the whole problem didn't occure: The remapping of
> the buttons worked fine in laptop and in tablet mode.
> What I tried so far:
> With "xsetwacom get "Wacom ISDv4 90 Pen stylus" all" I get an overview
> over parameters set with xsetwacom. There is an option: "TPCButton"
> "on". "TPCButton" means "Tablet PC buttons", I guess these might be the
> three buttons that I have issues with. But unfortunately if I switch
> this option to "off" nothing changes.
> By the way the output of "xsetwacom get "Wacom ISDv4 90 Pen stylus" all"
> doesn't change from laptop to tablet mode (for tablet mode, since I
> cannot reach the enter button, I tested it with "sleep 10 && xsetwacom
> get "Wacom ISDv4 90 Pen stylus" all". The 10 seconds delay I used for
> converting the device to tablet mode)
> My conclusion: I guess in ubuntu studio there is a driver that detects
> the signals from the sensor so the system "knows", that the display is
> turned and folded. And (what doesn't make much sense to me)
> unfortunately in tablet mode the three buttons are switched off.

I also have a convertible laptop. In my case, the keyboard and touchpad simply 
disable themselves from the hardware side. That said, if there is any thing 
turning it off software-wise, it's in the kernel which is beyond our control 
and is not an Ubuntu Studio issue. 

> Suggestion: If it is like that, the maybe easiest way to solve the
> problem, would be to switch off that detection or the service behind it.
> Does any of you know how to do that? Or do you have another idea, how I
> could get these buttons in tablet mode to work?

Again, this is not something that is user-controllable. It's likely hardware 
or at the kernel level. Linux doesn't have typical "drivers" like Windows; all 
drivers are part of the kernel.

> I hope I presented my problem understandable. If you need any further
> information, let me know!
> I would be really happy if you could help me! Even though the X220t is
> old, it still has plenty of power to cover the needs of graphical design
> with ubuntu studio. To make use of the full potential of the device's
> properties and ubuntu studio, using this three buttons in tablet mode
> would be awesome!
One of the next things we intend to add to Ubuntu Studio Controls is proper 
wacom table support, and since the Lenovo touchscreen is basically a Wacom 
tablet, we could use some help testing from that end.

Also, just note: Xfce (the desktop environment) not touchscreen friendly at 
all, and the Xfce developers have no intention of working on touchscreen 
support. Your best bet for touchscreen support at this point is a standard 
Ubuntu install with ubuntustudio-installer used to add those items.

I realize you are on 18.04, so make sure you have the Ubuntu Studio Backports 
PPA added. Information about all of this can be found at https://

> ps: What I just found out: It seems that the three buttons are
> interpreted as regular part of the keyboard. If I convert the device to
> tablet mode and stick a thin pen between the display and the keyboard,
> to press some keys of the keyboard while the sensor detects "tablet
> mode", also no input is detected. To me that means in tablet mode the
> whole internal keyboard is switched off.

That tells me it's definitely in the kernel. We have zero involvement with 
kernel development.

I hope that gives you a few pointers (pun slightly intended).
Erich Eickmeyer
Project Leader
Ubuntu Studio

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: This is a digitally signed message part.
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20200326/f11b0244/attachment.sig>

More information about the ubuntu-studio-users mailing list