[ubuntu-studio-users] Firewire interface

Israel israel at torios.org
Sun Apr 13 00:29:06 UTC 2014

Well, I am now dual booting [well... triple booting as I need MacOSX for 
my wife's phone :(   ]
I use Ubuntu 14.04 and Ubuntu Studio 12.04.  It works out of the box in 
Studio 12.04
I didn't have to try anything fancy.
I am using a Presonus Firebox.
I prefer to use only FLOSS and only want to install it rather than use a 
liveCD/USB/DVD (unless it is puppy), but thanks for your info.
I am in 12.04 right now, but if you need me to run some commands and 
post the output I would be glad to.  Presonus Firebox is already on 
FFADO (which is why I got it).
I got the interface specifically to use in Ubuntu... but 14.04 is having 
issues with it.
To enable it in Studio 12.04
Open the FFADO mixer, wait until it loads the device.
Open QJackctl and change it to firewire
Open Audacity (I haven't tried it in Ardour yet... I wanted to just see 
if it works) change it to Jack
Voila!  Working as expected.

So why doesn't it work in plain Ubuntu 14.04?  I tried MANY things, and 
all of them were useless.  Jack works fine with Alsa but not firewire.
If you like I can later post the output of the errors.

On 04/12/2014 11:16 AM, Mike Holstein wrote:
> On Sat, Apr 12, 2014 at 8:14 AM, Israel <israel at torios.org 
> <mailto:israel at torios.org>> wrote:
>     Hi,
>     I am having a few issues. I am using Ubuntu 14.04 (not studio) and
>     I am trying to set up a firewire interface, and I am having some
>     serious issues getting Jack to recognize it.
>     Can anyone point me in the direction of a good tutorial for how to
>     configure qjackctl so use my device.  FFADO Mixer loads the
>     interface just fine, but I cannot seem to figure out how to
>     configure everything to use it :)
>     The other issue is Ubuntu Studio 14.04
>     I downloaded the 32bit live (DVD) from current yesterday, and
>     Ubiquity goes fine until the place where I can choose the packages
>     to install.  Then a dialog pops up with a bunch of ???????? and
>     then the installer hangs up until I use a TTY to sudo reboot.
>     I have also tried booting the 64bit beta2 on a Macboot, and cannot
>     seem to boot into anything useful.  I am only allowed to choose
>     between the EFI boots on the USB, and none of those work.
>     Thanks for your help!
> when i migrated my production rig to linux, using a firewire interface 
> (as well as testing with may other internal and USB interfaces) these 
> are some helpful tips that i found made the transition possible.
> 1. work from a live CD. there are several nice live CD's these days, 
> such as our ubuntustudio live CD. when i say "live CD", i just refer 
> to the iso image, downloaded and running from whatever you need.. DVD, 
> USB, whatever.. while testing with the live CD's, you can easily tweak 
> *any* and *all* configurations, without the fear of breakage. this is 
> also an easy way to test different kernel versions and JACK versions 
> with your hardware. i like to use an ubuntu 12.04, and now, the 
> upcoming 14.04, as well as AVlinux's live iso
> 2. what is the issue? is it the firewire? or JACK? or permissions? or 
> what?
> test things as independently as possible. dont land in a new os, fire 
> up jack, with a piece of firewire hardware you dont know is supported 
> in linux. start with the internal audio device, and learn to configure 
> and run JACK using it. then, you can move forward knowing your JACK 
> configuration is working or not.
> 3. the firewire chipset *can* make or break linux support. you can run 
> "lspci" in a terminal and see what chipset you have for firewire.. 
> ideally, you have texas instruments.. if not, i have a few others that 
> work well, and also, a few that will never work in linux.
> 4. i have had laptops with IRQ issues relating to sharing IRQ for 
> firewire with USB ports i was using. you can check this in the 
> terminal with "cat /proc/interrupts"
> 5. keep in mind, none of the vendors of any of the hardware you have 
> have promised you linux support. a team of experts from many different 
> companies have come together for years and years to work with each 
> other and make sure that your hardware works in a different operating 
> system. you are basically deciding to take that responsibility on for 
> yourself.
> 6. temporarily running jack as root (which is not something i would 
> want to do all the time, continuously) can help troubleshoot 
> permissions. running "gksudo qjackctl" allows one to start jack as 
> root.. if jack has been failing, but runs as root, then, you know that 
> the hardware configuration in jack works, and that the issue is more 
> likely to do with permissions.
> 7. in qjackctl, there is a "messages" button that can have lots of 
> helpful information..
> feel free and share any terminal output here for any of the commands, 
> or the jack GUI error messages.. i suggest joining the IRC for 
> realtime help.
>     -- 
>     ubuntu-studio-users mailing list
>     ubuntu-studio-users at lists.ubuntu.com
>     <mailto:ubuntu-studio-users at lists.ubuntu.com>
>     Modify settings or unsubscribe at:
>     https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users
> -- 
> MH
> likethecow.com <http://likethecow.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20140412/5445cd3f/attachment-0001.html>

More information about the ubuntu-studio-users mailing list