[ubuntu-studio-users] dpkg error on libgmp10

David King linuxman at avoura.com
Fri Nov 8 10:39:00 UTC 2013

I am having a problem with updating any software on my Ubuntu Studio 12.04

There are various updates listed, but when trying to install them I get 
an error:

installArchives() failed: (Reading database ... dpkg: unrecoverable 
fatal error, aborting:
  unable to open files list file for package `libgmp10': Input/output 
error /var/cache/apt/archives/libgmp10_2%3a5.0.2+dfsg-2ubuntu1_amd64.deb
Error in function:
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (2)

/var/lib/dpkg/status contains the following entry:

Package: libgmp10
Status: install ok installed
Multi-Arch: same
Priority: optional
Section: libs
Installed-Size: 486
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Architecture: amd64
Source: gmp
Version: 2:5.0.2+dfsg-2ubuntu1
Depends: libc6 (>= 2.7)
Pre-Depends: multiarch-support
Description: Multiprecision arithmetic library
  GNU MP is a programmer's library for arbitrary precision
  arithmetic (ie, a bignum package).  It can operate on signed
  integer, rational, and floating point numeric types.
  It has a rich set of functions, and the functions have a regular
Original-Maintainer: Debian Science Team 
<debian-science-maintainers at lists.alioth.debian.org>
Homepage: http://gmplib.org/

I removed this from the status file and ran

sudo apt-get -f install

I am still getting errors, and libgmp10 is installed, and is the latest 
version, but Synaptic cannot list its installed files, and dpkg is 
getting an error reading its files

I have tried just reinstalling libgmp10 but it fails, I have tried 
updating the list of updates, I have tried updates via Update Manager, 
Synaptic and apt-get on the CLI.

Whatever I try to do I get an error with dpkg, and it is something to do 
with libgmp10. I am loathe to remove it as so much else depends on this 
vital software.

If I try
sudo apt-get install --reinstall libgmp10

The following output is shown:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer 
   gir1.2-ubuntuoneui-3.0 calligra-l10n-engb libhsqldb-java gjs 
   gir1.2-gdesktopenums-3.0 libubuntuoneui-3.0-1 libcmis-0.2-0
   gir1.2-gjsdbus-1.0 libgjs0c
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 33 not upgraded.
1 not fully installed or removed.
Need to get 238 kB of archives.
After this operation, 498 kB of additional disk space will be used.
Get:1 http://gb.archive.ubuntu.com/ubuntu/ precise/main libgmp10 amd64 
2:5.0.2+dfsg-2ubuntu1 [238 kB]
Fetched 238 kB in 1s (160 kB/s)
(Reading database ...
dpkg: warning: files list file for package `libgmp10' missing, assuming 
package has no files currently installed.
(Reading database ... 751863 files and directories currently installed.)
Preparing to replace libgmp10 2:5.0.2+dfsg-2ubuntu1 (using 
.../libgmp10_2%3a5.0.2+dfsg-2ubuntu1_amd64.deb) ...
Unpacking replacement libgmp10 ...
dpkg: error processing 
  failed to install updated files list file for package libgmp10: 
Input/output error
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

When trying to remove unneeded packages with apt-get autoremove
I still get the same errors

What can I do to fix this?

David K

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20131108/fead8656/attachment-0001.html>

More information about the ubuntu-studio-users mailing list