Wineasio, Guitar Rig and Jack issue on Maverik, AMD 64

NG noisyguitar at yahoo.com
Wed Dec 22 17:19:34 GMT 2010


Hi Ronan, Thanks for the fast reply!

I've tried the native apps you mention. "Calf plugins" have a nice
modulation tools that I'll be using, Scooperlooper will come in handy
indeed and as for Rakarrack, although it seems promising, lacks of a
good amp and overdrive/distortion emulator, and this functionality is
critical for the work I intent to do. The ideal thing would be using my
real amp and stomp boxes, but I live in a small place and I know I will
disturb the neighbours.  

I would love to be using pure libre/open source software and hope one
day Rakarrack becomes a great emulator, but in the mean time, Guitar Rig
is the only one that gets close (and works in linux)to the tone of my
real set-up. If anybody else know of any other open source emulator I
can try please let me know.

Anyway, I apologize for not providing further details. Here they are:

0. Kernel:  2.6.35-23-generic
1. Jack starts and run without interruptions (I've being testing it for
some days)
2. All native apps I've tried work smoothly (Ardour, Rakarrack, calf
plugin, Jack rack, Hydrogen, etc )

3. Never heard of Reaper. Just went to the website and installed the 32
bit version (tried 64 bit version but didn't work). In the "Audio
device" window I chose "ASIO" as my Audio device and then "Wine ASIO
Driver" in the next drop box. The drop boxes "Enable input" and "Output
range" are empty and when pressing the button "ASIO Configuration..."
nothing happens. 

When done, I got an error window: "Error initializing ASIO driver" :(

I have downgraded Wine to the default version (1.2) to narrow down the
possibilities and still using wineasio-beta_0.9.0~beta0_64bit.deb found
here: http://sourceforge.net/projects/kxstudio/files/DEBs/. Reaper was
installed over Wine 1.2.

BTW, to installed wineasio, I extracted the DEB file and copy
"wineasio.dll" to /lib32/wine/. then I run "regsvr32 wineasio.dll"
sucessfully and finally installed Reaper. Did it this way because I read
in a forum that the DEB was compiled using Ubuntu lucid not maverik, so
this method was suggested.

I'll  try to get into the IRC channel.

NG


On 10-12-22 02:34 PM, NG wrote:
> Hey guys!
> 
> ...
> 
> Any idea, suggestion or advice would be very much appreciated :)
> Thanks!
> NG

Hi NG!

You're asking for help on a complicated steam machine and we don't know
if each piece works independently, let alone the assembly. To help you
we need more background on your setup:
  0. Which kernel are you using? (use "uname -r")
  1. Does JACK start successfully? (can it run without interruption?)
  2. Do native JACK apps work? (can you work on Ardour, Rakarrack, etc.)
  3. *Does REAPER work?* (it should, REAPER supports WINE admirably). To
me, having confirmation of this last point would be very meaningful
since it would mean we are sure you have a sane wineasio setup. We'll
see about GR afterwards.

Finally, have you considered using native apps? I don't know your use
case but as a guitarist you should at least have a look at {Rakarrack,
Sooperlooper, JACK Timemachine, Calf plugins (and many others)}. WINE
apps are never a good idea; even if you get GR running tomorrow, you
_will_ end up unhappy (to be polite) someday. Which killer feature are
you missing?

Tell us about your progress; if you need direct help, feel free to ask
#ubuntustudio on Freenode.

Cheers,
Ronan Jouchet



-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20101222/79b62199/attachment.htm 


More information about the Ubuntu-Studio-users mailing list