Wineasio, Guitar Rig and Jack issue on Maverik, AMD 64

NG noisyguitar at
Wed Dec 22 13:34:16 GMT 2010

Hey guys!

I've being using ubuntu for some years now and I've just switch to
Ubuntu Studio as I'm a guitarist building a home recording studio. After
trying a Guitar Rig demo I've considered buying it as it covers all my
needs. I would be using GR, Ardour, Hydrogen and Jack. The only thing is
stopping me is that I'm having an issue with it in Ubuntu Studio Maverik
64 bit.

I have got Guitar Rig 4 running successfully on Ubuntu 10.10 32 bit,
however, in my 64 bit machine (UStudio 10.10) when I select the ASIO
driver in GR, nothing happens (it used to crash with other versions of
wineasio) and Jack can't see it. 

I am using the same audio interface (Edirol UA-25) in both systems and
I've tried different configurations in Jack without luck. What's
different though, is that in Ubuntu 10.10 32 bit, wine gets installed in
"/usr/lib" while in UStudio 64 bit, it goes to "/usr/lib32". I wonder if
this has something to do with the issue.

GR 4 is suppose to work in 64 bit machines (windows vista and 7 only)
but as I never saw an option (neither on the website or during the
installation) to install the 64 bit version, I'm assuming it
auto-detects it.

I'm currently using wineasio 0.9 and wine 1.3 but I've tried wineasio
0.7.5, 0.8.1, and wine 1.2 before. I've got the wineasio debs from here: and wine from the
official PPA.

I've read some threads on getting Guitar Rig working in linux but most
of them are outdated and don't address the issue I'm having.

I really need to get it running on the AMD64 machine as it was bought
for handling this task (music and video production). I've have
considered switching to Ubuntu Studio 32 bit if I don't get this sort it
out, but I don't want to loose computer power by doing it.

Any idea, suggestion or advice would be very much appreciated :)



-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Ubuntu-Studio-users mailing list