Jaunty RT testing

beejunk at gmail.com beejunk at gmail.com
Tue Apr 21 07:21:01 BST 2009

On Apr 20, 2009 7:03am, wayne <wayne at jawnee.org> wrote:

> On Sun, 2009-04-19 at 21:30 +0000, beejunk at gmail.com wrote:

> On Apr 19, 2009 2:00pm, wayne wayne at jawnee.org> wrote:

> > maybe it is not jackd that is stuck, but qjackctl, the QT gui for using  
> jack? if so, "killall qjackctl.bin" may work. the nice thing about  
> killall (at least on 8.04), is that after typing "killall", then entering  
> a space, then start typing the name of the process, you can use the Tab  
> key (ala Bash command completion) to finish the process name. when JACK  
> freezes, check with killall if jackd is even running. it may just be that  
> qtjackctl is stuck, which happens to me when the underlying jackd process  
> crashes: jackd dies, but qtjackctl is frozen. also, the qtjackctl process  
> will prob be "qtjackctl.bin", since that pre-script pauses PulseAudio  
> using paususpender before starting jackd... again, at least on 8.04. this  
> way, no PulseAudio getting in the way, while not having to totally remove  
> it.

> >

> >

> >

> > hope that helps.

> Thanks, I'll give these different techniques a shot, I'm sure one of them  
> will work. I'm still a bit baffled as to why the GUI for qjackctl was  
> changed at all to remove the ability to force quit. It worked fined in  
> Hardy, but with Jaunty the ability to just hit the 'X' button on the  
> windows and close it is now gone, along with the ability to right click  
> and hit 'force quit'. It's the same for any windows that JACK opens up,  
> such as the message window. Before, you could close it by hitting the 'X'  
> button, but now you must close it by hitting the 'Messages' button on the  
> GUI itself. Did they just want to make sure people were using the GUI to  
> do these things?

> -Brian

> not sure about the changes, as i am still using 8.04 Hardy. perhaps it is  
> as you said, making sure the qjackctl program can only be closed certain  
> ways, ensuring better cleanup of underlying jackd processes... or maybe  
> something changed in QT/GNOME/Metacity in 9.10 Jaunty. let us know if it  
> works.

> peace.

Well, I went to test some of these fixes out, and a surprising thing  
happened. I attempted to push JACK way beyond any reasonable limit in order  
to cause it to crash. But, instead of crashing, it simply. . .stopped, and  
allowed me to try different settings until something worked. That's  
actually very nice, and it eliminates the need to kill JACK in any other  
manner. Something must've changed in the last few days to cause this. I'll  
keep testing over the next few days to see if this behavior maintains. If  
this is the way JACK is going to act from here on out, then I have to say  
I'm rather pleased. Good job!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20090421/c8b6b29b/attachment.htm 

More information about the Ubuntu-Studio-users mailing list