Jaunty beta + RT + Jackd + Ardour, it works ;-D

laurent.bellegarde laurent.bellegarde at free.fr
Wed Apr 8 16:28:37 BST 2009

Hi everyone,

yesterday evening i've seen that there were 300 new packages for jaunty 
beta, so i download them and install them this morning, everything was good.

This afternoon, i've decided to test the new jaunty RT package seen 
yesterday evening.

so my  material are :

jaunty studio 32 bits
Hardy studio 64 bits

on intel 64bits dual core pentium 2GHz/4 Go/ati radeon HD3470 256Mo

so, i boot on jaunty rt kernel, with ati 2D free driver on (3D is out)

boot kernel : Linux laurent-laptop 2.6.28-3-rt #10-Ubuntu SMP PREEMPT RT 
Tue Apr 7 07:49:45 UTC 2009 i686 GNU/Linux

I've got 2 sound cards, a "bad one internal" and a not too bad external one.

internal card : 00:0f.0 Audio device: Silicon Integrated Systems [SiS] 
Azalia Audio Controller

external card usb : Bus 002 Device 002: ID 0ccd:0028 TerraTec Electronic 
GmbH Aureon 5.1 MkII

Under hardy, with rt, external one is fine, best latency is 2,9ms , 
internal one is bad with jack, best latency is close to 17ms in 48000

Under jaunty with rt, i get a error when i tried to tick RT check box,

14:02:12.874 Script de démarrage...
14:02:12.875 artsshell -q terminate
14:02:13.296 Script de démarrage terminé avec statut de sortie=256.
14:02:13.297 JACK démarre...
14:02:13.298 /usr/bin/jackd -R -dalsa -dhw:0 -r48000 -p256 -n2
14:02:13.314 JACK a été démarrer avec le PID=4263.
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread 
-1212610880, from thread -1212610880] (1: Operation not permitted)
cannot create engine
14:02:13.330 JACK a été arrêté avec succès.
14:02:13.331 Script post-extinction...
14:02:13.332 killall jackd
jackd: aucun processus tué
14:02:13.743 Script post-extinction terminé avec statut de sortie=256.
14:02:15.396 Impossible de connecter le serveur JACK comme client. - 
L'opération a échoué. - Incapable de se connecter au serveur. Veuillez 
consulter la fenêtre des messages pour plus d'informations.

same thing with external card hw1.

so i check the /etc/security/limits.conf, and the file wasn't complete 
as mentionned to be good, so i write it as mentionned to be good, and 
after a complete restart, no way tick the RT checkbox in qjackctl -> 
crash with hw:0 and hw:1.

by googling with this error

cannot use real-time scheduling (FIFO at priority 10) [for thread 
-1212610880, from thread -1212610880] (1: Operation not permitted)
cannot create engine

and with a lot of hazard and chance

i've tried to launch jack in a terminal, and discover that there was a 
problem of right to launch the RT kernel with jack.

So i've did that

in a terminal, launch qjackctl with a sudo qjackctl to be root, the RT 
kernel is fine until 2,9 ms with the both sound card !!! What a big 
suprise !!!
So RT kernel in jaunty is more efficient as Hardy's one. Then i launch 
ardour with sudo to be root and connect ardour to jack, and playing, 
recording music, editing goes fine, without any xruns !!!

Many congratulations to developpers, and to packagers, we are close to 
have a perfect distribution in Jaunty studio...

So packagers have to correct this problem of right to allow simple user 
(here it's laurent) to launch qjackctl with RT kernel as in hardy, and 
everythnig is ok.

Hope it helps,


More information about the Ubuntu-Studio-users mailing list