Jaunty RT testing

Brian David beejunk at gmail.com
Thu Apr 2 23:33:06 BST 2009

I've been reading this list in the archives for a while now, and decided to
join up so I could pitch in with the Jaunty Beta testing.  Still fairly new
to Linux, and to using e-mail lists for that matter, so keep that in mind as
you read this.

First up, here's my hardware.  It's a fairly old desktop that I use for

Motherboard: Asrock K7VT4A
Processor: AMD Sempron 2400+
Video: ATI Radeon 9600+
Memory: 2 GB
Audio Interface: Presonus Firepod

I grabbed the Beta on the day of its release, and the good news is that the
install ran smoothly and I had the RT kernel up and running after not too
much hassle.  I should say that I was using a regular Jaunty CD with the
UbuntuStudio audio and graphics meta-packages installed, and not the actual
UbuntuStudio CD.

My Firepod has always worked well with Linux, which I'm thankful for.  As
for performance, the freebob driver in Jack is essentially useless on this
computer, too many X-runs (although it seems to work great on my MacBook
booted into Hardy, which is my production machine).  However, the firewire
driver (FFADO, right?) works wonderfully.  I spent an hour or so messing
around with a simple three-track live recording, and there was not a single
X-run (JACK settings were Frame/Periods: 256, Sample Rate: 44100
Periods/Buffer: 3).

BUT, I ran into problems while trying to do my final mixdowns from Ardour.
To be exact, I couldn't mix down a full track without JACK shutting down.  I
tried easing the JACK settings back a little, but still no luck.  The tracks
would mixdown, but JACK would immediately then crash, and I'd have to
restart the Firepod and JACK to get things going again.  It's hard to tell
if this is due to the age of the computer, or the RT kernel.

Also, I ran into problems with some of the plug-ins in Ardour.  I found that
I could not adjust many of the settings (for instance, the frequency setting
in a parametric EQ I was using could not be changed at all).  I remember
reading on the Ardour website that there might be some problems with the
packages in the Ubuntu repos.  So I re-installed Ardour using a .deb I
downloaded from getdeb.net, and the problem disappeared.  Is this something
your package managers can fix?

The final HUGE glaring bug is that the RT kernel will not shut down or
restart.  When I try, it just freezes, and I need to shutdown the computer
manually.  This is not a problem with the generic kernel.

Overall, everything is working suprisingly well for a beta.  I'm really
looking forward to using this kernel on my MacBook.

-Brian David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-studio-users/attachments/20090402/5be7773b/attachment.htm 

More information about the Ubuntu-Studio-users mailing list