jaunty beta + kernel RT

laurent.bellegarde laurent.bellegarde at free.fr
Thu Apr 2 07:06:13 BST 2009

Luke Yelavich a écrit :
> On Thu, Apr 02, 2009 at 03:43:38PM EST, laurent.bellegarde wrote:
>> So after booting under 2.6.28-11-generic, i've look to theses packages, 
>> they are installed already.
>> i've tried your command
>> laurent at laurent-laptop:~$ sudo dkms -k 2.6.28-3-rt build  -m fglrx -v 8.600
>> [sudo] password for laurent:
>> Error! Your kernel source for kernel 2.6.28-3-rt cannot be found at
>> /lib/modules/2.6.28-3-rt/build or /lib/modules/2.6.28-3-rt/source.
>> You can use the --kernelsourcedir option to tell DKMS where it's located.
>> laurent at laurent-laptop:~$ sudo dkms --kernelsourcedir build  -m fglrx -v 
>> 8.600
>> laurent at laurent-laptop:~$
>> and then i reboot on RT-kernel, but same end, X crash and nothing work.
> Ok, you need to install linux-headers-2.6.28-3-rt, and then run the command I gave you again.

i've installed this package, done the command again, here is the terminal :

laurent at laurent-laptop:~$ sudo dkms -k 2.6.28-3-rt build  -m fglrx -v 8.600
[sudo] password for laurent:

Error! This module/version has already been built on: 2.6.28-3-rt
Directory: /var/lib/dkms/fglrx/8.600/2.6.28-3-rt/i686
already exists.  Use the dkms remove function before trying to build again.

a new boot with fglrx activated done the same trouble with X.

So a get a new boot under generic kernel, desactivate flgrx driver, free 
radeon driver has been activated, then a reboot on rt-kernel.

I've get a usable desktop. video resolution is ok, refreshing rate seems 
to be ok too. I didn't test acceleration and 3D effects, but under fglrx 
there is many trouble with compiz activated, so i'm waiting.

the loaded kernel was an rt one, as the command tell it :

laurent at laurent-laptop:~$ uname -a
Linux laurent-laptop 2.6.28-3-rt #9-Ubuntu SMP PREEMPT RT Fri Mar 27 
23:23:50 UTC 2009 i686 GNU/Linux

so, i load qjackctl and try rt with my two sound card.

- if i have rt on with internal sound card (bad one) hw0 -> jackd crash
- if i have rt on with external sound card USB (good one) hw1 -> jackd crash

and said this :

07:40:14.871 /usr/bin/jackd -R -dalsa -dhw:1 -r44100 -p64 -n2
07:40:14.887 JACK a été démarrer avec le PID=4403.
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread 
-1211967808, from thread -1211967808] (1: Operation not permitted)
cannot create engine
07:40:14.900 JACK a été arrêté avec succès.
07:40:14.900 Script post-extinction...
07:40:14.901 killall jackd
jackd: aucun processus tué
07:40:15.313 Script post-extinction terminé avec statut de sortie=256.
07:40:16.894 Impossible de connecter le serveur JACK comme client. - 
L'opération a échoué. - Incapable de se connecter au serveur. Veuillez 
consulter la fenêtre des messages pour plus d'informations.

for memory, hw1 is working fine under hardy studio 8.04 64 bits RT with 
64 frames/periode and 2,6ms for latency, hw0 is working but with few xruns.

i've done the same test, but without checking the rt checkbox in qjackctl.

same result for hw1 on usb, the sound card never work...and the 
frame/period change nothing.
for hw0, a surprising result, with 512 frame/periode, 26,3ms for latency 
(so a bad one), the card is working not too bas, with few xruns. I've 
tried at 256 frames/periodes with ardour reading a wav file, and 
hydrogen playing a drumkit, recorded in ardour, it's working with few 
xruns. below 256, too many xruns.

for conclusion, the internal sound card is working a little bit better 
than in hardy studio rt, but the usb one is not working at all.



More information about the Ubuntu-Studio-users mailing list