many problems after upgrade to Hardy

Gustin Johnson gustin at
Mon Jul 14 19:05:29 BST 2008

Hash: SHA1

| I have exactly the opposite experience.  I have been upgrading (as
| opposed to reinstalling) my laptop since dapper and it is still
| working flawlessly.
| I'm glad for you, but I have talked to others who have had similar,
| and worse, experiences--merely seach this list's archives and you'll
| see what I mean.  Gutsy was especially traumatic.

This is not "normal" in my experience.  This includes all the people in
my LUG who upgraded.

| I guess to start I would be interested in having a look at your
| /etc/apt/sources.list.
| OK, to save space I'll leave out everything that's commented out:

I also usually comment out the cdrom line as well.
The rest of the file looked fine.

| This looks good to me.  Yesterday, when I tried to sudo aptitude
| update, then sudo aptitude dist-upgrade, it didn't install or upgrade
| anything. I'll try again now:
| The following packages will be upgraded: gtk2-engines-murrine
| gtk2-engines-ubuntulooks libpoppler-glib2 libpoppler-qt2 libpoppler2
| linux-restricted-modules-2.6.24-19-generic
| linux-restricted-modules-common poppler-utils 8 packages upgraded, 0
| newly installed
| I'll save this draft and report back after I run the upgrade and
| reboot.
| later....
| Ok, now it won't boot at all.  It says it's going to check the drive,
|  then it just hangs there.
| "Ubuntu Studio has been mounted 22 times without being checked, check
|  forced. Checking drive Ubuntustudio (/dev/sda3): 0% (stage  1/5,
| 1/737) UbuntuStudio: 318790/12075008 files 95.2% noncontiguous),
| 6403122/24147703 blocks
| [blinking cursor]"
| It's been like that at least 10 minutes now, so I think that's all
| it's going to do.

I would also check the health of the hard drive if I were you.
~From a rescue cd (or even better a dedictated recovery cd like
systemrescuecd)  I would run fsck.ext3 -c -f /dev/sda1 (or whatever your
partition actually is).

| I'll try booting in recovery mode and send another e-mail with the
| results.
| FWIW I ran upgrade instead of dist-upgrade by mistake...but that
| shouldn't have hurt anything.

When you run uname -r what do you get?
Also run, sudo aptitude search linux-image |grep  ^i
Finally what is actually in /boot?  (ls -la /boot)

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


More information about the Ubuntu-Studio-users mailing list