many problems after upgrade to Hardy

Gustin Johnson gustin at
Fri Jul 11 07:53:58 BST 2008

Hash: SHA1

Paul DeShaw wrote:
| Greetings,
| After a more-or-less successful new installation of Ubuntu Studio 8.04
| on my Apple laptop, I decided to upgrade my desktop from Gutsy to
| Hardy.  I had been afraid to try, but the MacBook install was so pretty,
| I decided to take the plunge.
| Lots of things are weird now.  The 8.04 kernel was not installed, still
| running 7.10.
| There is no wallpaper.  The theme now has black letters against a dark
| brown background in dialog boxes in audio apps, almost impossible to
| read. The terminal is weird; the characters are rainbow colors, and they
| don't appear until after "enter" is pressed; there is a dark ghost
| window to the right of the terminal window.
| I tried running upgrade again with Upgrade Manager; it says the system
| is up to date.  I checked the sources and they are Hardy repositories.
| (Some apps have indeed been upgraded, which indicates to me that it is
| using the current repositories.) I tried upgrading from the terminal; it
| installed and upgraded 0 packages. I tried burning a DVD and upgrading
| from it; it installed the latest restricted modules, and removed 84
| obsolete packages, but everything seems to work the same.
| The sound does work; I ran JACK and Ardour, then Rosegarden.  Xruns
| galore, but I haven't played with the settings yet.   But, sound comes
| out from my external sound device like it should.
| So all that needs fixing **that I know about** is the terminal app, the
| wallpaper, and install the new kernel.  But who knows what else is
| messed up.   Should I:
| Install the kernel, terminal, and wallpaper from Synaptic or apt-get?
| Install fresh? (I have my home folder backed up on an external drive)?
| Something else I haven't thought of?
| This is so frustrating.  Ubuntu peaked with Dapper, as far as smooth
| upgrades are concerned.   I upgraded my old iMac G3 from Dapper to
| Feisty, and it's even more messed up.  Wish I'd learned my lesson and
| not upgraded my main desktop.

I have exactly the opposite experience.  I have been upgrading (as
opposed to reinstalling) my laptop since dapper and it is still working
flawlessly.  I have 3 machines at home that don't have problems with
upgrades either.   The servers I manage at work are even easier since
there is almost never a GUI (we just did a bunch of dapper to hardy
upgrades that went fine in addition to some 7.10 to 8.04 upgrades).  The
point is, the upgrade process should work fine, there is likely
something else going on).

I guess to start I would be interested in having a look at your

My personal preference is to use the CLI to do all my updates (far
faster than the GUI IMO, plus I am an old Debian user so I am used to
this procedure).  Once the sources.list file is changed:

sudo aptitude update && sudo aptitude dist-upgrade

usually sorts things out.  A quick reboot and I am in business again.

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


More information about the Ubuntu-Studio-users mailing list