many problems after upgrade to Hardy

Paul DeShaw pauldeshaw at
Fri Jul 11 07:19:25 BST 2008


After a more-or-less successful new installation of Ubuntu Studio 8.04 on my
Apple laptop, I decided to upgrade my desktop from Gutsy to Hardy.  I had
been afraid to try, but the MacBook install was so pretty, I decided to take
the plunge.

Lots of things are weird now.  The 8.04 kernel was not installed, still
running 7.10.
There is no wallpaper.  The theme now has black letters against a dark brown
background in dialog boxes in audio apps, almost impossible to read. The
terminal is weird; the characters are rainbow colors, and they don't appear
until after "enter" is pressed; there is a dark ghost window to the right of
the terminal window.

I tried running upgrade again with Upgrade Manager; it says the system is up
to date.  I checked the sources and they are Hardy repositories.  (Some apps
have indeed been upgraded, which indicates to me that it is using the
current repositories.) I tried upgrading from the terminal; it installed and
upgraded 0 packages. I tried burning a DVD and upgrading from it; it
installed the latest restricted modules, and removed 84 obsolete packages,
but everything seems to work the same.

The sound does work; I ran JACK and Ardour, then Rosegarden.  Xruns galore,
but I haven't played with the settings yet.   But, sound comes out from my
external sound device like it should.

So all that needs fixing **that I know about** is the terminal app, the
wallpaper, and install the new kernel.  But who knows what else is messed
up.   Should I:

Install the kernel, terminal, and wallpaper from Synaptic or apt-get?

Install fresh? (I have my home folder backed up on an external drive)?

Something else I haven't thought of?

This is so frustrating.  Ubuntu peaked with Dapper, as far as smooth
upgrades are concerned.   I upgraded my old iMac G3 from Dapper to Feisty,
and it's even more messed up.  Wish I'd learned my lesson and not upgraded
my main desktop.


-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Ubuntu-Studio-users mailing list