Ubuntu-Studio-users Digest, Vol 6, Issue 28

Hartmut Noack zettberlin at linuxuse.de
Sun Oct 28 10:28:31 GMT 2007

Hash: SHA1

jk at jasonkahn.net schrieb:
> hi again and thanks for your answers
>>>> i tried to recommended solution:
>>>>>>>> looks like your /etc/security/limits.conf is not set properly. An
>>>>>>>> Upgrade to studio seems to fail to set this, the install from DVD does
>>>>>>>> this OK. This file needs to have the following 3 lines at its end:
>>>>>>>> @audio          -       rtprio  99
>>>>>>>> @audio          -       memlock 860000
>>>>>>>> @audio          -       nice    -10
>>>> but this didn't seem to make a difference. is there something else i 
>>>> need to do?
>> what says:
>> #uname -a
> Linux

most strange that is: if I ask uname -a I get:

Linux zettberlin.msi 2.6.22-14-rt #1 SMP PREEMPT RT Mon Oct 15 01:05:51
GMT 2007 i686 GNU/Linux

The part "PREEMPT RT" tells, that I run a kernel that jack can use OK...

>> and:
>> #cat /etc/groups|grep audio
> No such file or directory

Sorry for the typo :-)  the file is *group* NOT group*s*

it should yield something like this:


>> If you got the rt-kernel running and if you are in group audio,
>> everything should be at its best...
> i don't understand here what you are referring to with "group audio."
> could you please explain?

In Linux you have certain priviledges as:

1.) a user (quite little but sufficient for dayly work).
2.) a member of one or more user-groups

To make audioapps run with the needed power in Linux smart people
invented a machanism that gives you, as the normal user certain
priviledges to access your computers hardware. To allow this the
usergroup "audio" is used:


 in the file /etc/group says, that the normal user jason is member of
group audio.

@audio          -       rtprio  99
@audio          -       memlock 860000
@audio          -       nice    -10

in the file /etc/security/limits.conf

says, that members of group audio are allowed to run software with
realtime-priority 99, lock down 860000 bytes of memory and start
processes that are 10 stages "more importent" then normal processes
running with the default nice -0.

Those priviledges can only be granted this way, if your running kernel
allows it. Thats why you need to run the RT-Kernel from Ubuntu
Studio/Universe and you need to be in group audio (can be set with the
user-tool in the system-preferences menu), to have fun with jack/Linux

that helps? ;-)

> with best regards
> jason

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the Ubuntu-Studio-users mailing list