[ubuntu-studio-devel] Ubuntu Studio Artful - Debian & Feature Freeze

Ross Gammon rosco at ubuntustudio.org
Wed Aug 30 06:27:14 UTC 2017

On 08/29/2017 11:41 PM, Len Ovens wrote:
> On Tue, 29 Aug 2017, Ross Gammon wrote:
>> On 08/29/2017 09:30 PM, Ross Gammon wrote:
>>> In fact, I was playing with it on Sunday, but it looks like I have no
>>> cpuFreq driver installed, so it didn't work for me (the governor in
>>> performance bit). But reading a wiki just now, I see that the driver is
>>> supposed to be loaded by cpufrequtils. So either the init script is not
>>> working for me, or I need to do a reboot. I will play some more in a
>>> minute.
>> A reboot does not fix it. I may have run into something like this bug:
>> https://bugs.launchpad.net/ubuntu/+source/cpufrequtils/+bug/1084262
>> More investigation required. Unfortunately I have to sleep now.
> I am not sure, does -controls have a dep for cpufrequtils? It has worked
> fine for me so far... I guess I need to try it on 17.10 as well. Make
> sure you have cpufrequtils installed (it is not by default).
> -- 
> Len Ovens
> www.ovenwerks.net

Yes, I think the dependency is there. When I installed the .deb it
complained, and apt-get -f install did the job of installing cpufrequtils.

But none of the kernel modules in my /some/path/kernel/drivers/cpufreq
directory are called cpufreq* something. They are called amd*something*.mo.
Apparently this causes some trouble for the init script in cpufrequtils
to load the module (at least for the people in the bugs - there are at
least two with similar problems since 2012). I ran out of time to try
loading one of them manually to see if I could set it to "performance"
after that.

Now I have to run to work......

More information about the ubuntu-studio-devel mailing list