[ubuntu-studio-devel] Ubuntu Studio Artful - Debian & Feature Freeze

Ross Gammon rosco at ubuntustudio.org
Wed Aug 30 20:11:16 UTC 2017


Hi Len,

Success!

On 08/30/2017 08:27 AM, Ross Gammon wrote:
> On 08/29/2017 11:41 PM, Len Ovens wrote:
>> On Tue, 29 Aug 2017, Ross Gammon wrote:
>>
>>> On 08/29/2017 09:30 PM, Ross Gammon wrote:
>>>> In fact, I was playing with it on Sunday, but it looks like I have no
>>>> cpuFreq driver installed, so it didn't work for me (the governor in
>>>> performance bit). But reading a wiki just now, I see that the driver is
>>>> supposed to be loaded by cpufrequtils. So either the init script is not
>>>> working for me, or I need to do a reboot. I will play some more in a
>>>> minute.
>>>
>>> A reboot does not fix it. I may have run into something like this bug:
>>> https://bugs.launchpad.net/ubuntu/+source/cpufrequtils/+bug/1084262
>>>
>>> More investigation required. Unfortunately I have to sleep now.
>>
>> I am not sure, does -controls have a dep for cpufrequtils? It has worked
>> fine for me so far... I guess I need to try it on 17.10 as well. Make
>> sure you have cpufrequtils installed (it is not by default).
>>
>>
>> -- 
>> Len Ovens
>> www.ovenwerks.net
>>
>>
> 
> Yes, I think the dependency is there. When I installed the .deb it
> complained, and apt-get -f install did the job of installing cpufrequtils.
> 
> But none of the kernel modules in my /some/path/kernel/drivers/cpufreq
> directory are called cpufreq* something. They are called amd*something*.mo.
> Apparently this causes some trouble for the init script in cpufrequtils
> to load the module (at least for the people in the bugs - there are at
> least two with similar problems since 2012). I ran out of time to try
> loading one of them manually to see if I could set it to "performance"
> after that.
> 
> Now I have to run to work......
> 

It turned out that I had to turn on "Clean & Quiet" in my BIOS settings.
Doh! Maybe we should add a note about that (and the equivalent Speedstep
for Intel) in the Help dialogue (or at least in the README).

Now I have had a little play & confirmed that I can change the governor
setting on the fly, and it survives a boot.

I did get a little muddled up once I started fiddling with the audio
settings. I lost jack-sink at one point. Which settings take affect when
you click "Apply Settings"? Is it all the interface card choices etc. at
the top, or just the three tick boxes at the bottom (jack sink etc.)?

Another minor thing I noticed is that it took 4 clicks to close down the
"help" dialogue, and it changed size each time.

Anyway, there were no crashes or annoying bugs. Should I try and get a
sponsor for an upload before the final beta?

Or is there anything you would like to tweak first? I will probably at
least add some notes to the README first.

It would have been nice to have it for the first Beta. But as usual, I
am too slow.

Cheers,

Ross



More information about the ubuntu-studio-devel mailing list