dialy build

Len Ovens len at ovenwerks.net
Thu Nov 10 00:32:53 UTC 2011



>> Install failed... seems a lot of our codec packages (libavcodec-extra-53
>> for example) have to have 0.7.2-1ubuntu1 gone.. does ubuntu1 need to be
>> deselected? I didn't save the log before I tried a second time...

> firstly i want to thank you for your initiative to test!  that's
> bloody amazing, mate :)

No problem... I have two extra drives for testing... but I am realizing I
could have done with one. The 40G usb drive could be used with either
machine I have. The bonus with the new drive in the desktop is that it is
better for testing audio flow from one kernel to the next... less likely
to be a bottleneck than a usb2 drive.

> i do not know if this specifically addresses the problem you are
> having but i am aware of a library that is in a transitional stage
> that is probably affecting ubuntu studio at some level.  the package
> is ia32-lib and i believe it is changing how it is built regarding
> multi-arch, although there is a good chance that i do not fully
> understand it completely.
>
Could be. However, it looks to me that Ubuntu is trying to get away from
some of the legally risky codecs by coming up with their own (possibly
closed source) codecs. I find it interesting it is linked to Ubuntu 1
(that is a one) which does music streaming. Some of the services are not
open or free. I would not be surprised if they were headed towards an
"itunes" like thing with pay per view/listen kinds of stuff. I have
nothing against that idea... but it may make things hard for some of the
codecs we need which are not just for consumer use but professional use
too... that is not encumbered by stuff to keep us from copying our own
product for example. I am not sure they want an official ubuntu deriv to
ship without it. But I suspect we need it out for at least some workflows.
Having a "warning this software needs to be removed to install this other"
may be good enough.

> for example, there is an automated email from colin watson that shows...
> ubuntustudio-meta 0.90 produces uninstallable binaries:
>  * ubuntustudio-desktop (amd64 i386)
>  * ubuntustudio-font-meta (amd64 i386)
>  * ubuntustudio-graphics (amd64 i386)

Ja, saw that. It accounts for the desktop issue, but not the codec issue.
I figured the sooner people were aware of extra problems the better. The
text with the fault is:

--------------8<----------------------------
Nov  9 14:58:25 in-target: The following packages have unmet dependencies:
Nov  9 14:58:25 in-target:  libavcodec-extra-53 : Conflicts: libavcodec53
but 4:
0.7.2-1ubuntu1 is to be installed
Nov  9 14:58:25 in-target:  libavformat-extra-53 : Conflicts:
libavformat53 but
4:0.7.2-1ubuntu1 is to be installed
Nov  9 14:58:25 in-target:  libavutil-extra-51 : Conflicts: libavutil51
but 4:0.
7.2-1ubuntu1 is to be installed
Nov  9 14:58:25 in-target:  liblensfun0 : Depends: liblensfun-data but it
is not
 installable
Nov  9 14:58:25 in-target:  libpostproc-extra-52 : Conflicts:
libpostproc52 but
4:0.7.2-1ubuntu1 is to be installed
Nov  9 14:58:25 in-target:  libswscale-extra-2 : Conflicts: libswscale2
but 4:0.
7.2-1ubuntu1 is to be installed
------------------------------8<----------------------

That does not look like transition library so much as an "either or" kind
of thing.

I would guess I should have been more specific as to what I meant. I had
to do yet another reinstall to get this text as I tried one with no
workflows installed that didn't have this problem.

Packaging and setting up distros is not one of my talents :) I am not sure
where to start learning. But this problem looks to me like a straight
conflict between two packages.

-- 
Len Ovens
www.OvenWerks.net




More information about the Ubuntu-Studio-devel mailing list