[Bug 1752411] [NEW] bind9-host, avahi-daemon-check-dns.sh hang forever causes network connections to get stuck

Launchpad Bug Tracker 1752411 at bugs.launchpad.net
Tue Aug 21 14:32:20 UTC 2018

You have been subscribed to a public bug by Trent Lloyd (lathiat):

On 18.04 Openconnect connects successfully to any of multiple VPN
concentrators but network traffic does not flow across the VPN tunnel
connection. When testing on 16.04 this works flawlessly. This also
worked on this system when it was on 17.10.

I have tried reducing the mtu of the tun0 network device but this has
not resulted in me being able to successfully ping the IP address.

Example showing ping attempt to the IP of DNS server:

~$ cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.


liam at liam-lat:~$ netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface         UG        0 0          0 wlp2s0 UGH       0 0          0 wlp2s0     U         0 0          0 docker0     U         0 0          0 docker0     U         0 0          0 tun0 UH        0 0          0 tun0   U         0 0          0 wlp2s0
liam at liam-lat:~$ ping
PING ( 56(84) bytes of data.
--- ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3054ms

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: openconnect 7.08-3
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Feb 28 22:11:33 2018
InstallationDate: Installed on 2017-06-15 (258 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: openconnect
UpgradeStatus: Upgraded to bionic on 2018-02-22 (6 days ago)

** Affects: avahi (Ubuntu)
     Importance: High
     Assignee: Trent Lloyd (lathiat)
         Status: Confirmed

** Affects: bind9 (Ubuntu)
     Importance: High
         Status: Confirmed

** Affects: openconnect (Ubuntu)
     Importance: Undecided
         Status: Invalid

** Affects: strongswan (Ubuntu)
     Importance: Undecided
         Status: Invalid

** Affects: avahi (Debian)
     Importance: Unknown
         Status: New

** Tags: amd64 apport-bug bionic server-next
bind9-host, avahi-daemon-check-dns.sh hang forever causes network connections to get stuck
You received this bug notification because you are a member of Ubuntu Sponsors Team, which is subscribed to the bug report.

More information about the Ubuntu-sponsors mailing list