12.04.2 LTS MaaS + PPA Juju doesn't work

Kyle Rankin ubuntu-server at greenfly.net
Wed Mar 20 02:27:35 UTC 2013


I'm trying to get Juju working with Maas on LTS so I can ultimately deploy
Openstack following the current steps on help.ubuntu.com [1].
Unfortunately I don't think anyone has tried deploying this combination
lately with the current juju from the PPA and the precise Maas. I ran into
two hurdles: 
1. The maas-import-isos that ships with precise has a bug that prevents 
maas-enlist from showing up [2]. I was able to get past this by following
the workaround in the launchpad bug for the issue. That involved directly
editing the maas-import-isos script on line 106 and hardcoding that the
release was precise. Anyway I got through that so that maas-enlist showed
up as a PXE option and I was able to enlist two test nodes. 
2. A bigger deal is that the current juju seems to expect the Maas/api/1.0/ 
path to exist on the maas server for its API call and this path is missing
in the version of maas that ships with precise. With this I wasn't able to
get any further. 

Now normally I guess you might suggest I just shrug and try 12.10 or
something newer but since my goal is to document how to get this working
specifically with LTS I'm stuck right now. To reproduce my issue it's as
simple as following the directions in the Maas docs to set up a Maas server
with precise from boot media [2], and then follow the same docs to install
the current juju from PPA and configure it for Maas [3]. Once you get to
the point where you are ready to juju bootstrap you should see the error.
Any suggestions?

Kyle Rankin

[1] https://help.ubuntu.com/community/UbuntuCloudInfrastructure
[2] https://bugs.launchpad.net/ubuntu/+source/maas/+bug/1070190/
[3] http://maas.ubuntu.com/docs/install.html
[4] http://maas.ubuntu.com/docs/juju-quick-start.html

More information about the ubuntu-server mailing list