I can't install ubuntu natty server on a iscsi root device

carlopmart carlopmart at gmail.com
Mon May 16 19:22:00 UTC 2011

On 05/16/2011 08:48 PM, Serge Hallyn wrote:
> Quoting carlopmart (carlopmart at gmail.com):
>> Hi all,
>>   I am trying to install natty server edition on a iscsi root drive
>> (iscsi target is a rhel6 host). During installation all works ok, I
>> can connect to iscsi target, partition disk, install packages, etc.
>> But when ubuntu reboots, nothing appears, screen is black.
>>   How can I debug this?? or Is this a bug?? I am installing this
>> natty server as a kvm guest under a rhel6 kvm host.
> It sounds like a bug, but to talk about it intelligently it'd be
> nice to have precise reproduction instructions.  I'd encourage you
> to file a bug, so we can collect all the information there.  Feel
> free to file it against 'qemu-kvm (Ubuntu)'.  If it turns out to
> be something else, we'll re-target it.
> To see how I tested iscsi last year, search for 'iscsi boot' at
> https://wiki.ubuntu.com/VirtFeatureVerification.
> thanks,
> -serge

Thanks Serge ... I didn't tried to make an iscsi install like appears here:


I have tried to install it directly to iscsi san like a physical host. 
Using berrange procedure is like to use RDM in vmware ... Very interesting.

But one question, can I use virtio device instead of ide like in 
berrange's doc appears for iscsi disk??

CL Martinez
carlopmart {at} gmail {d0t} com

More information about the ubuntu-server mailing list