some thing over wrote apache2 init script

Tapas Mishra mightydreams at
Wed Jul 6 01:25:01 UTC 2011

this is one problem with one of our servers I noticed today morning,
we are running a private cloud on Ubuntu server with KVM as hypervisor.

The URL is

The Dom0 on KVM instance where all the Apache settings are
I noticed

the apache2 file /etc/init.d/apache2 was blank
due to which rest of the internal sites were not accessible.

Also I noticed that there were other files


which were different instances of same file but these files were also blank.
Right now I have fixed it by copying the apache2 init script from one
of the internal machines.
So things started working back on track.

How ever on the machines running on LAN where our apps are there was
no such issue.

Let me know what can be the cause for such a thing  or what do I need
to investigate.
The problem happened recently.Though I have fixed it I want to know
what could have been a
possible reason for such a thing to happen.



More information about the ubuntu-server mailing list