RAID configuration failed during install

Tor Martin Slåen tormsl at
Fri Feb 11 22:26:47 UTC 2011

Hi everyone,

I guess this problem would affect the entire chain of ubuntu versions, but  
I subscribe to this list, so here it goes.

I had some problems getting a server to work today with my RAID  

I usually install servers with 2xRAID0 on the system disks, one partition  
/dev/md0 for swap, and one /dev/md1 for the root filesystem. I create two  
partitions on each disk before I configure the RAID. Usually, this works  
like a charm, but today this configuration failed. It seemingly created  
the raid arrays as it should, but after install and first boot, I got an  
errormessage saying that it was not able to mount root partition  
(/dev/disk/by-uuid/xxxxxxx) and was dropped to a rescue shell. I examined  
the RAID partitions, and saw that mdadm tried to assemble the swap array  
using /dev/sd[ab], not /dev/sd[ab]1 (notice the '1') which I had  
configured it to do. The same goes for the root array.

I tried running through the installer again (after zeroing superblocks and  
dd'ing about 400K from /dev/zero to both /dev/sd[ab]). I notised that  
after creating the RAID partitions and starting the RAID configuration  
tool, it would not recognize /dev/sd[ab][12], but could only recognize  
/dev/sd[ab] (the whole disk).

I could not get the installer to create partitions which could be  
recognized by the RAID configuration tool, so I had to use TTY2 to  
manually partition the disks using fdisk and creating the RAID arrays  
using mdadm. When I now ran the "Detect disks" step in the installer, the  
correct RAID arrays came up and I finished the installation. Now, booting  
was no problem and the server seems to behave like normal.

My question is; it this a known bug or is it my combination of hardware  
which didn't agree with the ubuntu installer?

This was during the installation of Ubuntu 10.04.1 Server amd64.

Tor Martin Slåen

More information about the ubuntu-server mailing list