work around for loading qlogic fibre channel card firmware in initramfs

James Dinkel jdinkel at
Thu Jul 2 17:14:07 UTC 2009

For anyone who is interested, the problem with not being able to access the
LUNs, even after getting the firmware loaded, is apparently a problem with
64-bit linux.  I tried Ubuntu, Debian, and Fedora 64-bit installs and none
of them could access the LUNs, but I did try Debian and Fedora earlier and
they must have been 32-bit installs and they could access the LUNs.  I'm
going to try reinstalling a 32-bit linux and make sure I can access the LUNs
with that and then maybe try compiling the 64-bit driver from QLogic instead
of using the built-in kernel module driver.


On Thu, Jun 25, 2009 at 4:34 PM, James Dinkel <jdinkel at> wrote:

> oops, I also meant to ask, if I submit a bug report, is there any more
> hardware or other information I should include other than what I've said in
> this list thread?
> Brazen
> On Thu, Jun 25, 2009 at 4:30 PM, James Dinkel <jdinkel at> wrote:
>> Installing multipath did nothing (as I figured).  So I've done a fresh
>> install of 9.04 Server and installed all updates.  I rebooted and did 'sudo
>> rmmod qla2xxx' and 'sudo modprobe qla2xxx' and thought the SAN disk shows
>> up, I can not access it.  fdisk and kpartx both give a read error.  I've
>> even tried downloading new firmware files from qlogic with no change.  This
>> works just fine in Debian Testing, so I'm thinking this must be a driver
>> issue.
>> Does anyone have any ideas?  Should I submit a bug report?  I really hope
>> this gets fixed before I have to give in and put *yuck* RHEL on this
>> machine.
>> Brazen
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-server mailing list