[Bug 1204069] [NEW] lxc dhcp fails

Andrew Stubbs 1204069 at bugs.launchpad.net
Tue Jul 23 11:14:04 UTC 2013

Public bug reported:

With the latest Saucy, LXC containers don't seem to have their network
setting configured correctly. I've tried this with both containers
created before I upgraded to Saucy, and containers freshly created after
the upgrade. In both cases, the guest user-space is 12.04.

After the container has started I try to find the address, but it fails:

$ host precise
Using domain server:

Host precise not found: 2(SERVFAIL)

Looking in the syslog reveals that it did try to obtain an address, and
dnsmasq did try to serve one (I think). The following is repeated many

Jul 23 12:07:27 GBN-ASTUBBS-UB dnsmasq-dhcp[1475]: DHCPDISCOVER(lxcbr0) 00:16:3e:9e:0f:ee 
Jul 23 12:07:27 GBN-ASTUBBS-UB dnsmasq-dhcp[1475]: DHCPOFFER(lxcbr0) 00:16:3e:9e:0f:ee 

But, still, nothing can get in, and nothing can get out.

Inside the container, ifconfig gives this:

eth0      Link encap:Ethernet  HWaddr 00:16:3e:89:48:ab  
          inet6 addr: fe80::216:3eff:fe89:48ab/64 Scope:Link
          RX packets:192 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:23650 (23.6 KB)  TX bytes:6952 (6.9 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

If I try running "sudo dhclient" manually then I get many more entries
in the log, but still no address.

I can get the network interface to function by configuring it manually:

ifconfig eth0
route add default gw
echo 'nameserver' > /run/resolvconf/interface/eth0
service resolvconf restart

I'm sure that the official way to set up a static IP would work too, but
really I want DHCP to work, like it used to.

** Affects: lxc (Ubuntu)
     Importance: Undecided
         Status: New

You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to lxc in Ubuntu.

  lxc dhcp fails

To manage notifications about this bug go to:

More information about the Ubuntu-server-bugs mailing list