[Hardware Certification] Release Meeting 2012-09-06

Brendan Donegan brendan.donegan at canonical.com
Thu Sep 6 15:59:19 UTC 2012

=== What was done engineering wise? ===

Quantal Alpha 3 testing completed. The list of bugs that will block certification if Quantal were released today is at:

https://chinstrap.canonical.com/~hwcert/blockers-quantal.html  <https://chinstrap.canonical.com/%7Ehwcert/blockers-quantal.html>

We'd like to have these bugs explicitly followed up on if not done so already, so we can try and unblock some of these systems before release. I will raise this again in the release meeting.

We've also resumed doing Quantal daily testing and Precise backports testing. At the moment everything looks fine with this and no bugs to mention.

=== What's about to land that might impact the other teams? ===

Nothing of note

=== Release Notes ===


=== Summary of bugs working on by team ===

The following bugs are blocking certification of systems with Precise (* means
new to the report):

1029101<https://bugs.launchpad.net/bugs/1029101>  [eMachines ER-1401-57] - Fails

Description was updated but no clear indication of whether the requested
mainline kernel tests were performed. Certification to  follow up with the cert
engineer to see what the status is on this one.

1016195<https://bugs.launchpad.net/bugs/1016195>  [Dell Latitude E6220] Crashes
or exits with signal 9 when under heavy load (TOP PRIORITY)

Still retesting, as the behavior seems to have changed after a reinstall. Flaky
hardware may be to blame.

992603<https://bugs.launchpad.net/bugs/992603>  [Lenovo E525] Touchpad can
become disabled after suspend/resume

This bug has moved on to bisecting around 3.4, since it looks like 3.3 is not going anywhere.

994274<https://bugs.launchpad.net/bugs/994274>  [Lenovo SL410] Mute button
requires you to hit a volume button

This is found to be a duplicate of

May be worth retesting since it's hard to follow the bug commentary.

994790<https://bugs.launchpad.net/bugs/994790>  [Dell XT3] Firewire does not work

Works with current Precise -proposed kernel (3.2.0-30.48). System still can't be certified due
to the bug listed below, but at least progress is being made!

994809<https://bugs.launchpad.net/bugs/994809>  [Dell XT3] Wi-fi slider doesn't
remove hard block from wi-fi device

Bug still remains upstream, needs following up.

978929<https://bugs.launchpad.net/bugs/978929>  [Lenovo Thinkpad T420]  SD
Card-reader non functional

This is an upstream issue and we opened
http://bugzilla.kernel.org/show_bug.cgi?id=43370. However we have a growing
suspicion that the card reader is actually broken on this system.

990575<https://bugs.launchpad.net/bugs/990575>  Entire desktop becomes
unresponsive after suspend/resume (TOP PRIORITY)

Certification to test some mainline kernels to determine the first bad kernel.

1002703<https://bugs.launchpad.net/bugs/1002703>  Broadcom STA driver can't
install on systems

Bug still occurs with -updates. Installing headers and brcmwl-kernel-source
leads to wireless working.

1014744<https://bugs.launchpad.net/bugs/1014744>  [Lenovo Thinkpad SL510] Mute
buttons don't work

This has also been marked as a duplicate of

1008867<https://bugs.launchpad.net/bugs/1008867>  can't wake up from suspend

A test kernel has been offered, but not tried yet.

992720<https://bugs.launchpad.net/bugs/992720>  [Lenovo E420s] Hitting
brightness keys causes machine to lock up

Bisection process is ongoing on this one and a test kernel is available, but not yet followed up on

759213<https://bugs.launchpad.net/bugs/759213>  [HP Compaq 6005 Pro] Suspend
does not resume

We need to open an upstream bug.

1012740<https://bugs.launchpad.net/bugs/1012740>  [Dell Latitude E6410] Becomes
unresponsive after suspending/resuming several times

Still testing hand spun test kernels to pinpoint the faulty commit. Behavior is
pretty consistent on this one so should yield good results.

1002170<https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1002170>  system
halted while idled for a long time.

Being worked on and upstream bug exists and has been linked

1009585<https://bugs.launchpad.net/bugs/1009585>  [Dell Vostro 460]: System is
unresponsive after Unity login screen.

We need to follow up on request to test a handspun kernel.

992087<https://bugs.launchpad.net/bugs/992087>  [Vostro 3450] No sound from
internal speakers

We need to raise an upstream bug and still need to test with a certified release
(11.04), to confirm it's not a hardware issue (machine may have broken since
being certified with 11.04).

=== Dependencies on other teams, blocking items? ===


=== Issues? ===


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-release/attachments/20120906/3f58580a/attachment.html>

More information about the Ubuntu-release mailing list