[Bug 1539284] Re: Firefox 44.0 repeatedly crashes on ARMHF

Henry Wertz hwertz10 at gmail.com
Tue Feb 2 01:54:14 UTC 2016

Since the bug's still open, I did have it reoccur but found the cause
and fixed it.  I had switched to the mesa libGL.so.1 to build some
software*, and firefox 44.0 runs with this, but did crash when I went
back to tegra libGL.  Long story short, the firefox profile's from my
previous portable and had gfx.blacklist.*, webgl.force-neabled and
layers.acceleration.force-enabled settings in there, clearing these
fixed it.  I cleared layers.acceleration.force-enabled last, this was
causing it in particular.

about:support indicates hardware accel is off (firefox disables on
nvidia driver less than 257.21, and tegra driver shows as nvidia version
21.4).  I looked to see if there was any bug report of recent layers-
related crashes (new between 43 and 44), but I didn't find anything;
presumably it works on supported drivers.

* The tegra libGL.so.1 causes dpkg-buildpackage to fail to build any
package that uses OpenGL, with an error that there is no dependency info
for libGL.so.1, but with mesa libGL.so.1 it builds fine and runs with
either libGL.

You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in Ubuntu.

  Firefox 44.0 repeatedly crashes on ARMHF

To manage notifications about this bug go to:

More information about the Ubuntu-mozillateam-bugs mailing list