[Bug 220575] Re: [MASTER] checking radio buttons or checkboxes doesn't work correctly

Gonzalo Servat gservat at gmail.com
Tue Oct 7 04:10:22 UTC 2008

Hi, I'm using Kubuntu as well and I had the same problem in KDE3. I decided to switch to Gnome (due to other reasons) so I installed the ubuntu-desktop dummy package. Anyway, I'm having the exact same problem in Gnome.
In Firefox/Epiphany, when I click on a checkbox, a dotted box appears around the checkbox and the contents are white so the box appears as if it wasn't ticked, even though it is. If I click outside the box, the checked-checkbox appears. With multiple select boxes, any selected items are not displayed as such until focus is given to the select box. Radio buttons also exhibit the same behavior as checkboxes. Strange thing is in Konqueror and Opera, it works fine. Only Firefox/Epiphany (and others, perhaps?) are affected so whatever engine they use to render these elements is evidently the problem.

I've tried the suggestion mentioned in this bug report of installing
gtk2-engines-qtcurve. I selected it as my "Control" theme in GNOME.
Restarted Gnome + Firefox and same result.

The closest I've come to fixing it is using some really weird theme in
System -> Preferences -> Appearance at which point checkboxes started
working OK, same as radio buttons, but I've not been able to fix the
multiple select options bit.

I'd appreciate any suggestions on this!

Thank you.

** Attachment added: "Screenshot showing the problem"

[MASTER] checking radio buttons or checkboxes doesn't work correctly
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in ubuntu.

More information about the Ubuntu-mozillateam-bugs mailing list