Version of rubygems is so old that it causes troubles
ubuntu at kitterman.com
Wed Mar 18 19:15:05 GMT 2009
On Wed, 18 Mar 2009 19:33:18 +0100 Lucas Nussbaum
<lucas at lucas-nussbaum.net> wrote:
>On 17/03/09 at 23:13 +0200, Vesa Vilhonen wrote:
>> Rubygems available from the intrepid repository has so old version
>Rubygems release dates:
>2008-06-21 => 1.2.0
>2008-09-25 => 1.3.0
>2008-10-28 => 1.3.1
>So, it's about as recent as all other software packages in Ubuntu
>> that some gems won't install with it
>That's a problem. Rubygems developers are so bad at providing backward
>compatibility that some newer gems can't install with a version of the
>packaging system released less than a year ago.
>> and it has been crippled from updating itself.
>That's your problem :-)
>> 1.3.1 is the latest version available. Please let me know if I
>> can help with this.
>It should be possible to provide a -backports package for 1.3.1. (it's
>already available in debian experimental)
We still have 1.2.0 for Jaunty too. Would recommend we update to 1.3.1
for this release (is there a reason that would be relevant to Ubuntu that
1.3.1 isn't in Unstable yet)?
More information about the Ubuntu-motu