GEOS 2.2.3-4 Ubuntu. PostGIS 1.3 is cited as needing GEOS 3.0.

barney holmes barney_holmes at
Mon Aug 4 16:09:44 BST 2008


(Note: please CC replies to me as I am unsure how to join the list at the moment).

I have GeoServer 1.6.4 setup on Ubuntu Hardy 8.04.1. 

It can connect to a PostgreSQL / PostGIS 1.3 database, with GEOS 2.2.3, but fails to be able to access spatially enabled columns.

According to the PostGIS documentation webpage ( ) PostGIS requires GEOS 3.0.

As mentioned in the GeoServer FAQ, GeoServer may hang if PostGIS does not have GEOS installed (see ). This is the behaviour I get, which would make sense as I only have the below recommended 2.2.3 version.

I am reluctant to jump into compiling such a complex system unless I really have to. Are there plans to release the GEOS 3.0 library for Ubuntu ? If I know it's coming along then I can plan around this and do other things in the meantime.


BTW this is for the Space Data Wiki project ( ).

DJ Barney

Portal, SpaceDataWiki: SourceForge Project.

Not happy with your email address?.
Get the one you really want - millions of new email addresses available now at Yahoo!
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Ubuntu-motu mailing list