Problème son avec C-Media PCI CMI8738

Vincent ROGER vince.roger at laposte.net
Mer 29 Déc 22:54:25 GMT 2004


Bonjour,
Je ne parviens pas à sortir du son à partir d'applications comme
Rythmbox ou Totem, mais par contre les CD-Audio passent bien avec le
lecteur de CDs Audio.
Ma configuration est assez standard : carte mère intel avec le chip son
désactivé au niveau du bios, une carte PCI USB 2.0, une carte réseau et
la fameuse carte son Hercules Gamesurround Muse Lt (C-Media PCI
CMI8738).
Il ne semble pas y avoir de conflits d'irq entre ces cartes.

J'avais déjà posté le problème mais à l'époque (il y a bien 2 semaines),
je ne savais même pas si la carte était reconnue, ou bien si le chip son
intégré n'avait pas la priorité : j'ai fait une réinstallation avec le
chip désactivé et ça n'a rien changé.

Je me suis documenté sur le sujet mais étant débutant sur Linux je
patauge pas mal.

Voici les fichiers qui à mon sens contiennent les problèmes :

Dans modules.conf, voici la partie concernant le son (je crois) :
        ### update-modules: start processing /etc/modutils/alsa-base
        above snd-pcm snd-pcm-oss
        
        ### update-modules: end processing /etc/modutils/alsa-base
        
Elle me parait bien vide, j'ai tenté d'insérer des arguments :

        ### update-modules: start processing /etc/modutils/alsa-base
        above snd-pcm snd-pcm-oss

        ### ALSA
        alias char-major-116 snd
        alias snd-card-0 snd-cmipci
        
        ### OSS
        alias char-major-14 soundcore
        alias sound-slot-0 snd-card-0
        
        ### Carte son 0 : CMI8738
        alias sound-service-0-0 snd-mixer-oss
        alias sound-service-0-1 snd-seq-oss
        alias sound-service-0-3 snd-pcm-oss
        alias sound-service-0-8 snd-seq-oss
        alias sound-service-0-12 snd-pcm-oss
        
        ### update-modules: end processing /etc/modutils/alsa-base

Mais ça n'a rien donné. Est-ce dans Alsa-base qu'il faut les ajouter ?

Voici ce que contient le fichier Oss_mixer :

        VOLUME "Master" 0
        BASS "" 0
        TREBLE "" 0
        SYNTH "Synth" 0
        PCM "PCM" 0
        SPEAKER "PC Speaker" 0
        LINE "Line" 0
        MIC "Mic" 0
        CD "CD" 0
        IMIX "" 0
        ALTPCM "" 0
        RECLEV "" 0
        IGAIN "" 0
        OGAIN "" 0
        LINE1 "Aux" 0
        LINE2 "" 0
        LINE3 "" 0
        DIGITAL1 "" 0
        DIGITAL2 "" 0
        DIGITAL3 "" 0
        PHONEIN "" 0
        PHONEOUT "" 0
        VIDEO "" 0
        RADIO "" 0
        MONITOR "" 0
Est-il normal que toutes les valeurs soient à 0 ?
Ou pas ?

Voilà où j'en suis actuellement.

Je serai très reconnaissant à quiconque m'apporte de l'aide : il me
vient des pensées mauvaises comme "si j'utilisais XP au moins je
pourrais écouter mes MP3", et mes enfants ne peuvent plus regarder leurs
dessins animés...  Help !!!





Plus d'informations sur la liste de diffusion ubuntu-fr