[ec2] Can't contact instance

Eric Hammond ehammond at thinksome.com
Tue Aug 4 23:23:05 BST 2009


I had, perhaps incorrectly, assumed you built your AMI by rebundling a
running instance of a public AMI.

Did you build your AMI from scratch using vmbuilder,
ec2ubuntu-build-ami, or by hand?

There are various EC2 specific boot tasks that need to be taken care of
without which you cannot connect to the instance.

Eric Hammond
ehammond at thinksome.com

Tom Haddon wrote:
> On Mon, 2009-08-03 at 19:44 -0700, Eric Hammond wrote:
>> Tom:
>> Right about the time you reported this, a higher than usual number of
>> other people reported similar problems on the EC2 forum.  There may have
>> been a localized networking or systems issue.
>> Amazon's AWS status board has not shown any problems at this point, so
>> it may have been temporary or isolated.
>> I would recommend trying to start new instances, perhaps in multiple
>> availability zones, to see if the problem is really with your AMI or the
>> environment.
> I tried starting instances of the AMI in all four availability zones and
> none of the instances were contactable. I'm going to try comparing my
> AMI with the stock ubuntu amd64 hardy AMI and see if I can see any major
> differences.
> Thanks, Tom
>> --
>> Eric Hammond
>> ehammond at thinksome.com
>> Tom Haddon wrote:
>>> Hi Folks,
>>> I'm getting a very strange issue with a particular AMI I've created.
>>> It's a x86_64 image, and I'm using the stock Ubuntu AKI/ARI
>>> (aki-6f709706/ari-61709708). I start an instance of my AMI and get the
>>> following console output:
>>> http://paste.ubuntu.com/246739/
>>> I can't login to the instance, or contact it via ping, even though:
>>> http://paste.ubuntu.com/246741/
>>> Any ideas what could be going on? From what I can see of the console
>>> output the machine has booted okay, but then I just can't contact it at
>>> all...
>>> Thanks, Tom

More information about the Ec2 mailing list