I'm getting XPath error in revision 501

Sean Wheller sean at inwords.co.za
Thu Feb 17 08:01:45 UTC 2005

On Thursday 17 February 2005 09:05, Jeff Schering wrote:
> I did svn update, and got revision 501.
> I decided to see what the quickguide looks like in yelp before doing
> any more work. This is the message in the terminal:
> jeff at cloud:~/ubuntu-doc $ yelp quickguide/quickguide.xml
> Use of deprecated SAXv1 function endElement
> I/O error : Attempt to load network entity
> http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd
> I/O error : Attempt to load network entity
> http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd
> XPath error : Invalid type
> Yelp starts up ok, but most of the pages are inaccessible ("The
> selected page could not be found in this document." is the error
> message).
> Everything works ok in yelp up until "Applications Menu -->
> Accessories". Even then, the page only displays the Archive Manager
> and the Calculator sections.
> I ran the validate.sh script, and it returns with no messages.
> I checked out revision 492 (because I know it to work - it's the
> version I checked out originally) and it works ok. There is no XPath
> error when yelp starts up with revison 492
> I tried to see if there was any difference in the tag structure
> between <sect2 id="qg-calculator" status="complete"> and the following
> sect2 <sect2 id="qg-charactermap" status="complete">, but nothing
> jumped out. Like I said earlier, yelp will not display anything past
> the calculator section.
> Is it me, or is it quickguide.xml?

It's neither. It's just Yelp does not know what to do with informal tables in 
an itemizedlist listitem :-( I have commented it in r502 so you can continue 
to work. I will test this later with a variablelist inside the listitem.

Sorry about that I should have checked if it worked under Yelp.

Call to GNOME: Shaum, if you are listening :-) informaltable is valid in 
lititem and yelp should work with it.

Sean Wheller
Technical Author
sean at inwords.co.za
Registered Linux User #375355
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-doc/attachments/20050217/63eb41c8/attachment.pgp>

More information about the ubuntu-doc mailing list