+1 maintenance day report

Paride Legovini paride at ubuntu.com
Mon Jul 18 17:30:45 UTC 2022

Note: search the message for "HANDOVER" for what I believe is a bitesize
task that will unblock a migration (I didn't get to it in time).


I spent some time trying to figure out why autopkgtests for src:pyside2
take between 2 and 3 hours in Ubuntu and about 25 minutes in Debian, see:

- https://autopkgtest.ubuntu.com/packages/pyside2/kinetic/amd64
- https://ci.debian.net/packages/p/pyside2/unstable/amd64/

but I didn't get to a definitive conclusion. The only thing I can say
is that I don't think there's a single step slowing down the test run,
but it's overall slower. The test has a lot of dpkg operations, and
hence a lot of filesystem sync operations. Perhaps the Debian infra
is making more/better use of eatmydata-like tricks.

Coming to migration excuses, I worked on:

 - holding 18 other packages
 - causes two regressions:
   - cluster-glue/1.0.12-20ubuntu/ppc64el
     Retriggered and it passed, see:
   - adduser/3.121ubuntu1/i386
     This one requires a hint (thanks bdmurray and vorlon for the pointers):
   - hint merged (thanks vorlon)
 - perl should be able to migrate now.

 - holding 7 other packages
 - mini transition (src:coquelicot needs to be rebuilt)
 - A new src:coquelicot upload is already in -proposed, but the arm64
   build was unlucky and built against the old version of ssreflect.
 - Did a no-change rebuild upload of src:coquelicot
 - The autopkgtest now pass: 
 - I expect the package to now be a candiate.

 - holding 4 packages
 - Causes test regression on src:surf on armhf.
   It was already retriggered by jbicha. I tried again and it failed.
 - I triggered a surf autopkgtest run without -proposed triggers
   (trigger=surf/2.1+git20220504-1). It failed, so the failure has
   actually nothing to do with webkit2gtk.
 - Passes in Debian:
 - I didn't get to the bottom of this.

 - holding 3 packages, 50 days old 
 - mini transition, did no-change rebuild uploads of:
   - perl6-readline
   - raku-tap-harness
 - retriggered builds of (previously FTBFS on all archs):
   - raku-getopt-long (succeeding, s390x not built yet while writing)
 - we'll see if there's anything else blocking with the next britney run.

 - holding 3 packages
 - missing builds on all archs but riscv64
 - reason: missing b-deps (riscv64 got lucky because it slow)
 - retriggered builds; built everywhere but on arm64.
 - reason for missing arm64 build:
   The following packages have unmet dependencies:
    libcoq-mathcomp-bigenough : Depends: libcoq-mathcomp-ssreflect-94ef7
   E: Unable to correct problems, you have held broken packages.
 - HANDOVER: I think we just need a no-change rebuild of
   src:mathcomp-bigenough to rebuild against a newer ssreflect.

 - holding 3 packages
 - causes regression in glyphslib/5.3.2+ds1-1
 - the failure also happens in Debian:
 - Debian (release critical) bug:
 - filed update-excuse bug linking to the Debian bug:

 - holding 2 packages
 - direct autopkgregression on armhf, with error:
   AssertionError: dtype('int64') != <class 'int'>
 - I wasn't expecting this to ever pass on armhf and did a
   migration-reference/0 retrigger, but it actually passed!
 - I expect the package to now be a candiate.
 - cool that we have a tool for microbiome analysis :)

 - missing build: s390x
 - retrigged build and it worked
 - I expect the package to now be a candiate.



More information about the ubuntu-devel mailing list