[dom at earth.li: Upcoming perl 5.14 transition]

Colin Watson cjwatson at ubuntu.com
Sun Nov 13 17:59:35 UTC 2011

We're early enough in our release process that I think we should go
ahead with this transition in Precise as well.  perl-modules is 1.3MB
smaller in Perl 5.14 due to no longer installing Unicode database files,
so this would be worthwhile for that alone.  Also, using 5.14 for the
LTS would get us an extra 13 months of security support from upstream,
up to May 2014 (http://perldoc.perl.org/perlhist.html,

Debian has been preparing for this for some time, and there are
currently only eight bugs in client packages listed as blocking the
transition, which is entirely manageable.

I'm happy to shepherd this transition.  While the transition to Perl
5.12 involved some base system disruption, I do not think that we will
see the same problems with Perl 5.14, thanks to the
debconf-english/debconf-i18n rearrangements in debconf 1.5.39.

Any objections?

Colin Watson                                       [cjwatson at ubuntu.com]
-------------- next part --------------
An embedded message was scrubbed...
From: Dominic Hargreaves <dom at earth.li>
Subject: Upcoming perl 5.14 transition
Date: Sun, 13 Nov 2011 13:59:19 +0000
Size: 52459
URL: <https://lists.ubuntu.com/archives/ubuntu-devel/attachments/20111113/be04ad99/attachment-0001.mht>

More information about the ubuntu-devel mailing list