We'd like you to use Launchpad web service version "1.0" in Lucid

Martin Pitt martin.pitt at ubuntu.com
Tue Mar 30 16:57:57 BST 2010

Leonard Richardson [2010-03-30 10:44 -0400]:
> 1. When testing, make sure you're using launchpadlib 1.5.7 or later. A
> bug in earlier versions made launchpadlib use the 'beta' service in some
> circumstances even when you told it to use another version.

Right, that's what I stumbled on today, too. I synced 1.5.7 into lucid
now, and extensively tested with Apport.

Please bump the binary dependencies accordingly when doing the

> Does this sound doable? What packages need to be ported to 1.0? Can we
> do this in time for the Lucid release?

It should be noted that in case a port gets too hard for a package
(although the transition is straightforward), we can still change it's
login_with() call to use version='beta' explicitly, even with
launchpadlib 1.5.8.


Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
Url : https://lists.ubuntu.com/archives/ubuntu-devel/attachments/20100330/541231b1/attachment.pgp 

More information about the ubuntu-devel mailing list