UEC/Eucalyptus installation test: 20090927.1

Dustin Kirkland kirkland at canonical.com
Mon Sep 28 05:28:48 BST 2009

On Sun, Sep 27, 2009 at 11:47 AM, Thierry Carrez
<thierry.carrez at canonical.com> wrote:
> Matt Zimmerman wrote:
>> There are some errors printed on the console during startup which I think
>> have to do with registration failing:
>> "ERROR: you need to be on the CLC host and the CLC needs to be running"
>> (screenshot attached).  I didn't file a bug about this, because I assume it
>> is nothing new, just auto-registration still not working.
> This is usually because the web services are not really up when
> registration is tried, see my other email to Dustin.

Right, this was my change, dropping a 2>/dev/null on registration.

Up until now, we've just been silently hiding the fact that
registration on init is failing.  We can put that back in, if
necessary, but personally, I think we're sweeping the breakage under
the mat by sending that error message back to /dev/null.

I'll also note that "CLC host" should be more explicitly described in
the error message.


More information about the ubuntu-devel mailing list