20090929.2 UEC install test

Thierry Carrez thierry.carrez at canonical.com
Thu Oct 1 07:32:45 BST 2009

Dustin Kirkland wrote:
> I spent today testing Eucalyptus on the beta candidate.
> I installed with the current beta candidate, which includes
> eucalyptus_1.6~bzr854-0ubuntu12.  I confirmed that walrus registration
> worked, and sc and cc registration was broken.
> At this point, I upgraded both the CC and NC machines to the latest
> eucalyptus in the archive, the one that includes the fixes I uploaded
> last night, eucalyptus_1.6~bzr854-0ubuntu13.
> Immediately upon upgrade, all 3 components successfully registered.
> For good measure, I rebooted the system at this time.  Upon reboot,
> all components were again registered successfully.  The web interface
> correctly reflected the setup.  I then registered the NC properly,
> without incident.  The NC immediately started polling.  I could run
> euca-describe-availability-zones and see my cloud availability.

Note that by rebooting after first successful registration, you work
around bug 439251. Eucalyptus probably still needs to be restarted after
first successful registration of components to be usable. Note that it
never needs to be restarted after that, it's just that it ignores
components that were just registered, until the next restart.

This is a little tricky to solve, since we register again on restart. We
probably need to implement some logic to *not* try re-registering if its
already registered... and/or fix it in upstream code.

> Next, I started the extremely lengthy task of registering and running
> images.  This part takes a very, very long time.  1-2 hours, to be
> honest.  I followed (and updated) the steps at:
>  * http://testcases.qa.ubuntu.com/Install/ServerEConfig

Yes, it's a very lengthy process, one of the reasons why I didn't
consider a late ISO respin to be a viable option, especially while I was
the only one to test the UEC-from-CD install. It's good that you are in
this capacity as well now.

> I was able to bundle, register, and upload the image.  I also
> submitted the run job, and it immediately went into the pending state.
>  Monitoring the NC, I watched as 10GB's were transferred over the
> network, and then Eucalyptus dd'd a new image, and eventually the
> image made it to the running state.

Yes, first instance run takes a very long time.

> Once it was in the running state, I was able to obtain the boot
> console messages with euca-get-console-output.  The image came up, but
> was having networking issues.  You can view the console log attached
> to this bug:
>  * https://bugs.edge.launchpad.net/ubuntu/+source/eucalyptus/+bug/439288

I can run the beta candidate just fine. Maybe you should submit this
issue as a separate bug ?

> At this point, I strongly believe that the
> eucalyptus_1.6~bzr854-0ubuntu13 upload is better than the -0ubuntu12
> upload.  I don't think that it regresses the state of the package, and
> it does fix several bugs.  We're still a ways from a complete, working
> UEC, but we're getting there.  I believe that -0ubuntu13 solves the
> majority of the registration issues, and I am very much able to run
> instances with that version.

There are two possibilities here.

1/ There was a test glitch in my environment. Testing full installs with
ISOs containing -ubuntu13 should confirm that.

2/ There is an issue introduced by the install-from-CD process that you
don't get by installing packages over a running system (or upgrading).
Testing full installs with ISOs containing -ubuntu13 should confirm that.

In both cases we need a daily ISO to test. But we need several testers
and the test takes a long time. We cannot afford to screw up the beta
release for that test.

> I don't particularly care whether -0ubuntu13 makes it on the beta ISO,
> but I definitely don't think it should be reverted from the archive.

I'm going to confirm that installing the beta with -0ubuntu12 and
upgrading to -0ubuntu13 doesn't screw up *anything*. If that's the case,
then yes, I think we should *not* revert the -0ubuntu13 upload. It is
one step closer to the autoregistration grail. Then starting Friday
we'll get an ISO with -0ubuntu13 on it to check the remaining issues, if

Note that I'm pretty sure bug 439251 isn't solved at that point, so even
supposing an ISO with -0ubuntu13 would work everywhere, we still have a
manual step to complete registration. So we can't reach the beta target
of automatic configuration anyway.

Thierry Carrez
Technical lead, Ubuntu server team || Canonical Ltd.

More information about the ubuntu-devel mailing list