Heavy printing regression in Jaunty: SRU?

Till Kamppeter till.kamppeter at gmail.com
Thu Jun 4 17:51:04 BST 2009

One follow-up:

One important Poppler bug which needs to get fixed for the SRU, too is

   Poppler's pdftops fails to convert a PDF file to PostScript

I have fixed it and added the fix (a very simple patch) to the Poppler 
debdiff in


and also submitted it upstream 


Till Kamppeter wrote:
> I had some discussion on IRC whether or not to issue an SRU for Jaunty 
> on a big problem with printing.
> See
> https://bugs.launchpad.net/bugs/382379
> During the Jaunty release cycle I have switched the pdftops CUPS filter 
> (filter which turns PDF print job data into PostScript) from using 
> Poppler to using Ghostscript becuase the Poppler solution did not 
> support documents which contain pages of different sizes. As the Poppler 
> developers were not willing to fix this problem, I decided on switching 
> to Ghostcript and Jaunty got released that way. See
> https://bugs.launchpad.net/bugs/310575
>   A3 pdf file is cropped and printed on A4 paper
> https://bugs.launchpad.net/bugs/329991
>   Poppler's pdftops does not support multiple-page-size output, use
>   Ghostscript for the CUPS filter instead
> Unfortunately, this caused many regressions, especially for users of 
> PostScript printers, which makes the support of PostScript printers by 
> Jaunty very bad, whereas this class of printers is considered the best 
> supported by Linux. Also the cups-pdf print-into-PDF-file facility and 
> many third-party (manufacturer) drivers got broken by that.
> The problems are jobs not getting printed due to huge temporary files 
> filling up the hard disk, extremely slow printing, corrupted font 
> characters, no searchable text, incompatibility with PostScript 
> interpreters in printers, ...
> Regressions are reported as these bugs (there are more than these bugs 
> and some of these bugs have also duplicates):
> https://bugs.launchpad.net/bugs/377011
>   Cannot print documents to Laserjet 4350, via network
> https://bugs.launchpad.net/bugs/362186
>   Spurious lines on print outs
> https://bugs.launchpad.net/bugs/289852
>   intrepid: printing very slow
> https://bugs.launchpad.net/bugs/381788
>   [jaunty] cups-pdf no longer embeds fonts in pdf file
> https://bugs.launchpad.net/bugs/372166
>   No output when printing in Ubuntu 9.04
> https://bugs.launchpad.net/bugs/375763
>   printer wont print although ubuntu says that job is compleated, also
>   driver wont update
> In all these bugs I have asked the users to replace their pdftops CUPS 
> filters by a test script which uses Poppler and not Ghostscript. All 
> users who answered told that the test script solved their problems.
> Simply returning to Poppler would reintroduce bug 310575/bug 329991 
> (documents with pages of different size), but in the mean time I have 
> found a simple fix for Poppler to solve this bug, see
> https://bugs.freedesktop.org/show_bug.cgi?id=19777
> The debdiff for our Poppler package is attached to
> https://bugs.launchpad.net/bugs/382379
> and the fixed Poppler package will soon get uploaded into Karmic. I will 
> let the reporter of bug 310575 test the fix.
> So we can fix all the regressions with simple fixes in two packages, the 
> mentioned Poppler patch and a patch to CUPS to use Poppler again and to 
> call Poppler's pdftops the right way. This means, with the new 
> "-origpagesizes" when the CUPS option "fitplot" is not given, never 
> using "-noembtt" as this causes missing text characters in some cases 
> (see bug 362186 and bug 381788) and not emitting PostScript Level 3 (see
> bug 277404). As the fix in Poppler prevents the reappearing of bug 
> 310575/bug 329991 there is no known regression when returning to Poppler.
> So I am thinking about applying the two small changes to Poppler and 
> CUPS as an SRU for Jaunty. WDYT?
>    Till

More information about the ubuntu-devel mailing list