8.04.1 to Intrepid upgrade test

Matt Zimmerman mdz at ubuntu.com
Fri Jul 4 17:55:36 BST 2008

With 8.04.1 safely out the door, I decided to brave an upgrade to Intrepid.
All told, it was pretty rough going, but most of it was to be expected at
this early stage.

= Upgrader =

 * update-manager -d behaved as expected

 * Early on in the upgrade, findutils bombed out (LP #243830)

 * This triggered a cascading failure of many packages, since findutils is a
   dependency of libc6.  update-manager displayed an excessive number of
   dialog boxes to report the failures (fixed in update-manager 1:0.91.7
   according to mvo)

 * I cleaned up the mess manually using apt-get, and things seemed more or
   less stable

= Reboot =

 * I clicked the panel icon to reboot, but the shutdown dialog didn't come
   up.  For about two minutes, my keyboard and mouse were grabbed, and while
   the panel continued to update, I couldn't do anything.  Oliver suggested
   that this might be traceable to gnome-power-manager, as it queries that
   before displaying the dialog.  When it came up, I canceled it, and tried
   to reproduce the problem, but failed (so no bug report)

 * When I did reboot, I got the gdm greeter instead of usplash while the
   shutdown process ran (LP #126797).  I could see shutdown messages by
   switching to vt#7.

= X =

 * After reboot, I encountered a black screen for perhaps 30 seconds.  I
   tried to switch to vt#1, but still nothing was displayed.  Switching
   to vt#7, I saw the "low-graphics mode" dialog.  I launched the
   configuration tool, which showed that the vesa driver was in use, and
   I attempted to switch it back to nvidia.  This failed, but it was
   impossible to understand why from the tool (LP #245582)

 * I attempted to use displayconfig-gtk to fall back to the nv driver, but
   was stymied because it did not let me use a mode larger than 800x600
   (LP #150467).

 * I also noticed what appeared to be a bug in its test mode (LP #245583)
   and that the half-implemented "location" drop-down is still there
   (LP #133909), but read in the latter that displayconfig-gtk is apparently
   being abandoned, so I suppose the last four bugs were in vain.

= Kernel =

 * Switching to a text console, I found that the reason for the failure was
   that the nvidia module was missing entirely (LP #243863)

 * apparmor seems to be missing as well:

   ls: cannot access /sys/module/apparmor: No such file or directory
   ls: cannot access /sys/module/apparmor: No such file or directory
   $Loading AppArmor module: Failed.
   invoke-rc.d: initscript apparmor, action "start" failed.
   ls: cannot access /sys/module/apparmor: No such file or directory
   ls: cannot access /sys/module/apparmor: No such file or directory
   ls: cannot access /sys/module/apparmor: No such file or directory
   $Loading AppArmor module: Failed.
   invoke-rc.d: initscript apparmor, action "reload" failed.

   The patch seems to be missing from the kernel tree.

 * At this point, I gave up on 2.6.26 and rebooted back into 2.6.24.

 * I set about trying to get the old nvidia module working, but ran into
   problems.  At first, the module wouldn't load because the install rules
   in /etc/modprobe.d/lrm-video failed, because they tried to invoke
   /sbin/lrm-video, which disappeared from linux-restricted-modules-common
   (LP #240942).  Further investigation showed that /sbin/lrm-manager was
   also missing.

 * I downgraded linux-restricted-modules-common to get around this, and
   downgraded nvidia-glx-new to match linux-restricted-modules-2.6.24.  This
   seemed to get the driver working again, and I started GDM.

= Desktop =

 * I logged in (still at 800x600) and ran displayconfig-gtk to fix the mode.
   It successfully changed the mode for my session, but once it was changed,
   it became unresponsive (grayed out by compiz), followed by my
   gnome-terminal and the panel.  I had to zap X with control+alt+backspace
   to continue.

 * At this point, I regenerated a clean X configuration with
   'dpkg-reconfigure -phigh xserver-xorg', which gave me the nv driver and
   the correct video mode.

 * I logged in, and noticed that my panel layout was scrambled, presumably
   due to having logged in at 800x600 (LP #36189)

I'm now more or less up and running again, though I haven't fixed my panels
yet.  Things which seem to have upgraded OK:

 * Dovecot IMAP and delivery (maildir indexes took some time to regenerate)
 * Firefox
 * Mutt
 * NetworkManager (simple wired config)

 - mdz

More information about the ubuntu-devel mailing list