apt-ftparchive release generates broken Release file

Joe Cooper joe at virtualmin.com
Wed Aug 29 00:04:30 BST 2007

Howdy all,

I've got an apt repository that I've been maintaining with 
dpkg-scanpackages, but now I'd like for the repo to be signed.  I've 
switched over to apt-ftparchive for the generation of the relevant 
meta-data files.  Everything seems to be working OK, except the Release 

When I run:

apt-ftparchive -c /home/joe/etc/apt-gutsy-release.conf release 
dists/gutsy >dists/gutsy/Release

In the root of my ubuntu repository tree, the resulting Release file 
lists itself as a zero length file, with an invalid MD5 sum, like this:

  d41d8cd98f00b204e9800998ecf8427e                0 Release
  068f132aef8266fb88fa5e33ff8dab54            38252 

Everything else looks legit, but I can't figure out what to do to make 
that Release entry go away (the official Ubuntu repos don't have 
self-referential entries like that, so obviously somebody knows how to 
do it).

When I run apt-get update I get an error like this:

Failed to fetch http://localhost/ubuntu/dists/gutsy/Release  No MD5Sum 
entry in Release file 

Which I'm guessing is this bogus 0 sized Release entry (but I'm happy to 
be wrong, if I'm after a red herring).

I've been unable to find any documentation on running or configuring 
apt-ftparchive, beyond the man pages (which don't provide any examples), 
so I've been shooting in the dark for days without any luck.  If there's 
some better way to build signed repositories, I'm happy to use other 
tools.  I just need to figure out how to build and manage a signed 

Thanks for any pointers you can provide.

More information about the ubuntu-devel mailing list