non-root can't access dv device

Duncan Lithgow dlithgow at
Fri Mar 17 18:48:20 GMT 2006

I'd love to work with someone to get Kino working for Dapper - anyone?

One problem (since breezy) is that only root can do any capture (export is
borged too, but that's another story). Anyone else gets the error: "WARNING:
raw1394 kernel module not loaded or failure to read/write /dev/raw1394!"
I've checked /dev/raw1394 and the disk group has rw permissions, adding my
normal account to the disk group doesn't help.

Someone a while back suggested that the problem was with udev, which should
trigger the module when the camera is plugged in. I don't understand what
that means but is that the problem?

Someone suggested this might help, but it doesn't:
duncan at 5634303B:~$ sudo modprobe raw1394

Someone gave me this to make the module is there, it is.:
duncan at 5634303B:~$ sudo ls -l /lib/modules/`uname
-rw-r--r-- 1 root root 36573 2006-03-09 19:49
duncan at 5634303B:~$

A kino developer () says:
"Duncan, I am the lead developer of Kino. The crashing in Capture is
reported by
other Ubuntu users in the forum. I run Kubuntu Breezy at work on
stock kernel, and I can not reproduce it."

When I tried kubuntu it gave me exactly the same trouble.

Anyone care to look into this with me?

PS: as root capture from firewire works fine, but export to mpeg doesn't:
"Error writing to KINO/MJPEG audio filter - aborting" - i'm also looking
into that problem...
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the ubuntu-devel mailing list