grub, large drives, and old bios

Adam Lydick lydickaw at
Tue Mar 22 03:03:52 CST 2005

On Mon, 2005-03-14 at 21:40 -0800, Adam Lydick wrote:

> I thought I had exhaustively tried all combinations when I hit this
> problem in debian, about 4 months ago. I checked again and noticed the
> translation mode was set to "manual" instead of "LBA". It is entirely
> possible that I've done something foolish ;)
> I'm still puzzled that it "just worked" with LILO + LBA option.
> Since my BIOS settings were rather odd (and I already worked around it),
> we can probably just drop the issue entirely.

I tried again with a recent installer-daily (~2 days ago) and my BIOS
configured to what I believe to be sane settings (LBA mode) and I'm
still seeing problems @stage 1.5:

18 : Selected cylinder exceeds maximum supported by BIOS 
        This error is returned when a read is attempted at a linear
        block address beyond the end of the BIOS translated area. This
        generally happens if your disk is larger than the BIOS can
        handle (512MB for (E)IDE disks on older machines or larger than
        8GB in general).
It's possible that I'm still doing something incorrectly, but it would
probably be a good idea to document the /boot partitioning workaround in
the release notes just in case someone else hits this. 

A better solution might be to provide a way to do this via the menu so
the FAQ can just say "choose this option from the installer menu"
instead of guiding a novice through 20 steps of partitioning settings.



More information about the ubuntu-devel mailing list