grub, large drives, and old bios

Adam Lydick lydickaw at
Mon Mar 14 23:40:36 CST 2005

On Mon, 2005-03-14 at 11:05 -0800, Matt Zimmerman wrote:
> On Mon, Mar 14, 2005 at 03:03:46AM -0800, Adam Lydick wrote:

> > One of my workstations has a large drive (200GB) and an older bios that
> > doesn't seem to support GRUB. (I've only gotten it to work with LILO,
> > previously) Thus, the standard warty install fails to boot.

> Did you try changing the geometry settings for the disk in the BIOS ("Auto"
> or "LBA" are good options to try); that often fixes this kind of problem
> (though you didn't mention which GRUB error you saw).

I thought I had exhaustively tried all combinations when I hit this
problem in debian, about 4 months ago. I checked again and noticed the
translation mode was set to "manual" instead of "LBA". It is entirely
possible that I've done something foolish ;)

I'm still puzzled that it "just worked" with LILO + LBA option.

Since my BIOS settings were rather odd (and I already worked around it),
we can probably just drop the issue entirely.



More information about the ubuntu-devel mailing list