Bugs in amd64 build of xorg?

Kristian Berg kriberg at tihlde.org
Wed Mar 9 05:23:32 CST 2005

Hi, I'm having some very strange bugs appear in hoary. I'm playing world
of warcraft using cedega in a 32bit chroot. This has worked fine since I
bought the game in January, but when I logged on this Saturday it didn't
work all to well. This is the error code I get:

$ cedega WoW
mmtime pid=18111 tid=18127
X Error of failed request:  GLXBadLargeRequest
  Major opcode of failed request:  145 (GLX)
  Minor opcode of failed request:  2 (X_GLXRenderLarge)
  Serial number of failed request:  252087
  Current serial number in output stream:  252088

The game worked fine last Thursday, so perhaps one of the updates to
xorg or something related which came after Thursday broke it? Running
stock kernel and stock nvidia module. 

According to some googling, this bug is related to communication between
64bit and 32bit xservers. I suppose this bug is quite difficult to
reproduce on other systems if you don't have the same setup, so I'll be
happy to provide with any debugging info. I haven't done anything
special with my configuration of any sorts during the last week, except
running dist-upgrade, so to me, it seems like a change in the build of
xorg caused this.

Kristian Berg

More information about the ubuntu-devel mailing list