Problems in Hoary (was Re: Installation reports)

Danilo Šegan danilo at
Wed Feb 2 07:43:42 CST 2005

Today at 7:39, Matt Zimmerman wrote:

> I can't trash an i386 system at the moment, but I assume others have tried
> that.  How does it look?

Do dist-upgrade'd systems count?

I'm having problems with the kernel, and it's most likely an upstream bug.

- 2.6.7 from Warty Live CD works fine, except that udev doesn't want
  to start (so I force it to start by changing /etc/init.d/udev
  script), and CD's are not auto-detected  (everything else works,
  like USB 2.0 and 1.1 usb-storage devices, sound, usb cdc_acm ISDN
  modem,...); that's the kernel I'm using now 

- 2.6.8 from Warty installation has a faulty cdc_acm driver, but other
  than that, it works flawlessly with Hoary

- 2.6.10 (linux-image-2.6.10-2 2.6.10-12 I think was the latest I
  tried) constantly halts or borks;  on boot-up, cdc_acm device works,
  but after one connection, it doesn't work anymore; hot-plugging
  usb-storage devices halts the system (though not always; if I umount
  the device first, it *sometimes* doesn't halt the system [if I
  haven't written anything on it; it otherwise halts even on "sync"],
  and if I plug it back in, it even sometimes re-enables the cdc_acm
  device);  doing /etc/init.d/hotplug stop also halted the system

I've tried compiling 2.6.11-rc2 kernel, but since it was my first
attempt at compiling kernel with 2.6 series, I probably messed
something up, and keyboard and mouse didn't work in GDM login screen.
Then I was left without time to dig in further, so I'll see if
there're some changes in 2.6.11 rc kernels which fix this for me, and
if so, I'll post them in Bugzilla.

Of course, all of this is tightly related to the hardware I'm using.
This is a Dell Inspiron 1100 laptop, and I can list further details if
anyone thinks it'll be worthwhile.

I also have some problems with new components in Gnome (i.e. Gnome
System Tools "network-admin" and new "modem applet" are not working
for me, so I simply use "pon" and "poff").  I'll try to track that
down as well, and see if it's upstream problem, or Ubuntu problem.


More information about the ubuntu-devel mailing list