Obsoleting python2.1, python2.2 in Hoary

Matt Zimmerman mdz at canonical.com
Thu Dec 23 18:24:28 CST 2004

On Thu, Dec 23, 2004 at 05:05:33PM -0500, David Mandelberg wrote:

> Matt Zimmerman wrote:
> > With the Python 2.4 transition well in hand in Hoary (thanks to Matthias and
> > the others who worked on this), it is time to think about which versions of
> > Python we will support in Hoary.
> > 
> > I propose that we drop Python 2.1 and Python 2.2 at least, and perhaps
> > consider dropping Python 2.3 as well if we don't find any regressions in
> > 2.4.
> > 
> > Thoughts?
> > 
> Maybe they could be moved to universe instead of just being dropped. That way
> they don't need to be supported as much but are still there if somebody needs them.

The pythonX.Y packages could, of course, continue to exist in universe.
However, support for these versions would need to be dropped from native
module packages (otherwise, they would require the corresponding
pythonX.Y-dev packages in order to build).

 - mdz

More information about the ubuntu-devel mailing list