Broken dependencies which are required and I can't fix

Jeffrey Walton noloader at
Tue Jul 13 01:26:15 UTC 2021

On Mon, Jul 12, 2021 at 2:34 PM Kelechi Mba <kelechimba11 at> wrote:
> I'm a new Ubuntu user and I have come across some troubles. I have some broken dependencies which is making me not able to use the apt-get command. I've tried reinstalling and removing the packages using the Synaptic Package manager but I always come up with some errors.
> The packages that are broken are libcrypt1:i386, libgcc-s1:i386, libidn2-0:i386, liblz4-1:i386, libudev1:i386, and libunistring2:i386.
> When I tried reinstalling the packages I get the error "E: Internal Error, No file name for libgcc-s1:i386" and I don't know how to fix it. How do I fix this?

In the old days you just installed ia32-libs.

Nowadays you do something like this:

    $ sudo apt-get install lib32z1 lib32ncurses5
    $ sudo apt-get install gcc-multilib gcc-7-multilib
    $ sudo apt-get install g++-multilib g++-7-multilib

You should check the version of GCC that comes with the platform and
use the specific version when installing. My -m32 test system happens
to use GCC 7 by default, hence gcc-7-multilib and g++-7-multilib.

If you have dependencies, then you use the <package>:i386 syntax, like:

    $ sudo apt-get install libfoo:i386

Also see, which is kind of
dated nowadays.


More information about the Ubuntu-devel-discuss mailing list