compatibility issue in environment-modules version 4.1.1-1

Josefsson-Ljungdahl goslju at
Sun May 5 18:21:29 UTC 2019

Hi Robie,

Seeing that you have attached a signature it would help if you could point
me to your public key. You can find mine at public key-servers. The
fingerprint is: 57AA BFB8 727A 2506 47CC  CB90 2D23 4815 7026 0357. Look
for gostal at or perhaps some part or all of dsa1024/70260357.

Ok, I will make a bug report. I thought about doing it but I was not sure
whether this would qualify as bug. According to a colleague of mine Debian
does not let /bin/sh point to /bin/dash if the user has chosen e.g. bash as
his or her shell. But googling just now I'm not so sure. I'll double check
with my colleague. If things are as he says Debian would not be affected
unless the chosen shell i dash, of cource. I'll also find out about Debian
version and version of the environment-modules package. If he has installed
environment-modules I can ask him to check the scripts for #!/bin/sh or
send them to me. But that'll have to suffice. I can't guarantee that it'll
be the latest versions.

Thanks for responding. The Mint fora have not been overly helpful, I must

Best wishes,

Den sön 5 maj 2019 kl 19:35 skrev Robie Basak <robie.basak at>:

> Hi,
> I would start by making sure a good quality bug report exists against
> the Ubuntu package, and if relevant, the Debian package. It would help
> if you could report in that bug if the problem is fixed in the latest
> version of the package in Debian, and which releases of Ubuntu are
> affected. Then it will be more obvious to developers where the fix needs
> to be made and what work might be required.
> Thanks,
> Robie
> On Sat, May 04, 2019 at 03:49:51PM +0200, Josefsson-Ljungdahl wrote:
> > Hi.
> >
> > I wish to report an issue regarding environment-modules version 4.1.1-1
> in
> > universe/devel. I run Linux Min 19 but this issue lies with Ubuntu. It's
> > not really a bug, more of a compatibility problem. According to the files
> > in the package this software is meant to be initialised during login
> since
> > it puts a file under /etc/profile.d/ named which in turn
> sources
> > initialisation files under /usr/share/modules/init depending on the
> user's
> > shell. The initialisation fails because some files contain the shebang
> > #!/bin/sh which means that /bin/dash runs those files in particular a
> file
> > which sets up the shell command "module". The commands are then exported
> as
> > are a number of environment variables but apparently dash does not
> entirely
> > cope with this as the commands are not available when a terminal session
> is
> > started although the set environment variables are.
> >
> > I use bash and I changed /bin/sh to point to /bin/bash instead of
> > /bin/dash, logged out and logged back in and the initalisaion worked as
> > expected.
> >
> > I would suggest that the package be patched to cope with the user's
> choice
> > of shell provided it is supported by the package. Needless to say, dash
> is
> > not supported.
> >
> > I do not know if Ubuntu sources /etc/profile during graphical login but
> > Mint does. In case Ubuntu doesn't I would suggest that the installation
> of
> > the package puts a sourcing line in ~/xsessionrc or tells the user to do
> > so, at least tell the user what to do to make it work.
> >
> > I would really appreciate this to be done. The software is really handy
> and
> > many would welcome a pacage installation that works as intended.
> >
> > You can find details of my trials and errors here:
> >
> >
> > If someone wishes to contact me in this matter please send a mail to
> > gostal at
> >
> > Kind regards,
> >
> > Gösta Ljungdahl
> > --
> > Ubuntu-devel-discuss mailing list
> > Ubuntu-devel-discuss at
> > Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Ubuntu-devel-discuss mailing list