problems about dependency of mysql-server-5.5-dbgsym

Gareth academicgareth at
Tue Sep 15 09:11:01 UTC 2015

On Tue, Sep 15, 2015 at 4:59 PM, Robie Basak <robie.basak at> wrote:
> On Tue, Sep 15, 2015 at 11:51:11AM +0800, Gareth wrote:
>> the same package from different (but related) repo has different
>> dependencies. One is '(= 5.5.35+dfsg-1ubuntu1)' and another is '(=
>> 5.5.44-0ubuntu0.14.04.1)'. The first on from trusty and breaks in
>> installation if I don't set ddebs' trust-updates in apt source.
>> Is that a bug?
> If I understand you correctly, no, this isn't a bug. If you want debug
> symbols you need to have ones that were built with the package you have
> installed, so there must be an exact version match. If you're installing
> from trusty-updates from the archive, then you need ddebs from
> trusty-updates.

I know this. But at the first time I enabled ddebs' trusty only (no
trusty-updates yet), I got errors from running apt-get install this
package. Because the mysql-server's latest version is
5.5.44-0ubuntu0.14.04.1, and the dbgsym package from trusty repo is
5.5.35+dfsg-1ubuntu1. After enabling trusty-updates, I got what I
need, the dbgsym package with 5.5.44-0ubuntu0.14.04.1

> If you still think this is a bug, then please can you explain your use
> case?
> Thanks,
> Robie


Cloud Computing, OpenStack, Distributed Storage, Fitness, Basketball
OpenStack contributor, kun_huang at freenode
My promise: if you find any spelling or grammar mistakes in my email
from Mar 1 2013, notify me
and I'll donate $1 or ¥1 to an open organization you specify.

More information about the Ubuntu-devel-discuss mailing list