Jaunty 64-bit and NVIDIA -- Any ideas?

Davyd McColl davydm at gmail.com
Wed Jun 10 06:01:30 UTC 2009

Good day

Thanks for your response. Suspecting that there could be a problem with the
card itself (rather inconveniently coincidental, since I just bought a new
mobo, psu and ram after a power surge (as far as I can ascertain) killed my
PSU and I wasn't sure exactly what was dead, and just wanted to cover my
bases; also, as noted in the OP, I reloaded, going from 32bit Jaunty to
64bit -- that seemed like the most likely culprit since 2D was working fine
and 3D worked for a while), I bought an XFX GTX260 -- I've wanted to upgrade
for the last year or so anyways... No problems now. (:

I still find it odd that 2D worked flawlessly and 3D worked for a short
amount of time -- about 5 seconds for glxgears and anywhere from 5 minutes
to a few hours for GL screensavers... But perhaps there was a circuit in the
"3D parts" (I'm no electronic engineer!) which was damaged and just needed
to warm up a little through usage to become blatantly broken.

I'm going to give the card to someone else to test -- will report back. If
the card works fine for someone else, then I really don't know how how to
proceed with debugging this. I would have to assume that if the card isn't
faulty elsewhere, then someone else may encounter the same issue.

I'm still annoyed by the "nvidia flicker" on my laptop -- but apparently
that's a long-standing issue (allegedly the quick black flicker is from the
onboard gpu changing power usage / clock levels).

To answer all posed questions (because it would be rude not to (:  ). Some
answers are from memory, so please bear with me:

1) glxinfo showed the usual large amount of stuff -- with the gl extensions
supplied by NVIDIA
2) Yes, the NVIDIA closed driver was not only installed, but in use -- lsmod
confirmed this (I also started to wonder...)
3) I did have compiz-fusion enabled. Never had the problem before, but I do
believe I tried disabling compiz and still found simple apps like glxgears
to cause lockup. See the wierdness? Compiz-fusion worked fine (with all its
GL interaction), but something with a little more demand wreaked havoc)
4) Yes, totally up-to-date. Compulsively so (:


On Wed, Jun 10, 2009 at 12:41 AM, Dane Mutters <dmutters at gmail.com> wrote:

> On Mon, 2009-05-25 at 07:59 +0200, Davyd McColl wrote:
> > Good day
> >
> > I've used Ubuntu for quite some time (years), following upgrade cycles
> > on 32-bit and staying clear of 64-bit just because a lot of people
> > have reported having a hard time of it. I recently installed 64-bit
> > Jaunty on my laptop (HP Pavillion dv9352 with NVIDIA 7600 go graphics)
> > and it worked so swimmingly that I decided to finally do a clean
> > 64-bit install on my desktop instead of just dist-upgrade'ing to
> > Jaunty as I would have normally done.
> >
> > Things have been good for a while -- but the problems have started as
> > soon as I've required 3D applications to work. It started when I
> > switched from "Blank Screen" to the "BlinkBox" screensaver. I came
> > back to my machine to find it locked up after a while. This process
> > was repeatable. Suspecting gnome-screensaver, I uninstalled and
> > installed xscreensaver instead -- no change. And other 3D screensavers
> > (like Bouncing Cow) cause the same issue.
> >
> > When I was playin Diablo II via WINE last night, I got a lockup after
> > about 20 min play. All system temps are well within normal operating
> > ranges -- the hardware doesn't seem to be the problem. <ALT>-<SYSRQ>
> > keys still work, so the kernel is still alive. Suspecting graphics,
> > I've downgraded from the 180 driver to the 173 -- same effect. The
> > older 96 (iirc) driver doesn't seem to allow compiz, but does seem to
> > suck just as much -- glxgears brought the system to a standstill, with
> > occassional response from the mouse cursor -- but nothing else. I must
> > also note here that glxgears quite reliably reproduces the system
> > lockup for the 173 and 180 drivers.
> >
> > My next recourse is to try the beta (185) drivers from NVIDIA. I would
> > have already but the download I left going overnight apparently broke
> > somehow: the installer is complaining about a checksum mismatch -- so
> > I'm re-downloading.
> >
> > What I want to know is: is this common for 64-bit systems (to have
> > dodgy proprietary (ie, NVIDIA / ATI) drivers)? I've seen a lot of
> > posts online about similar issues but they range right from Warty days
> > -- has this always been an issue? Should I have rather just stuck with
> > 32-bit? And does anyone know of aything other than trying the beta
> > drivers which I can give a bash? I'm not a hectic gamer, but I do like
> > to play something now and then (doom, quake, diablo, serious sam,
> > etc), and it sucks that I'm unable to use a simple GL screensaver.
> >
> > Any ideas are appreciated.
> >
> > -d
> Hi, Davyd.
> I've been playing around with a few different motherboards at work, and
> have found that some of the ones with built-in 3d accelerated graphics
> behave oddly when the 3D drivers are installed.  (Some of them will
> exhibit the behavior you've described, even though they're up to spec
> for running a given application.)
> That being said, perhaps you could post (or attach) the output of this
> command?  (Omit the '$'--as you probably know, it's part of the command
> prompt.)
> $ glxinfo
> Also, please post or attach your /etc/X11/xorg.conf file, and the output
> of the command, 'lsmod | grep nvidia'.  I'm interested in knowing
> whether the nVidia driver is actually being used, or if it's installed
> but disabled for some reason.
> Do you have Desktop effects (compiz-fusion) enabled?  Try turning them
> off; perhaps the problem lies in compiz, not in the driver.
> I take it you've gotten all the system updates via the Update Manager?
> If not, it might be a good thing to do.
> I may not be a devel, but at least I can help troubleshoot. :-)
> --Dane Mutters

Truth doesn't cease to be just because you don't agree with it.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-devel-discuss/attachments/20090610/22d95f82/attachment.html>

More information about the Ubuntu-devel-discuss mailing list